Main Site Documentation

Powering UsbClientDP drops USB connection


#1

Working my way through a couple of things tonight so first question is why when I plug in a power supply to my UsbClientDP (both versions 1.2 and 1.3) does it drop my USB connection as reported by MFDeploy for example (ie my app fails to deploy). Typically I have no problem powering my Gadgeteer projects, but I’m having problems with a project using a WiFi_RS21, so I thought I would add some extra power to the project hearing that the WiFi_RS21 sometimes needs some extra juice. I’m using a class 2 plug in transformer at 9v 1000mA center positive (actually a Linksys plug from one of my routers).

I should mention I was powering a Spider v1.0 board.

I trust I’m doing something wrong, I just need to know what it is so I can stop doing it :slight_smile:

Thanks


#2

Looking at TPS2115 datasheet(http://www.datasheetcatalog.org/datasheet/texasinstruments/tps2114.pdf), figure 4, you can see that there can be a drop on the voltage while switching from one power input to the other. On the DP module you have that on the 5V rail which in turn drops to 3.3V and powers the spider. Maybe that is making the spider reboot or somehow affecting the usb peripheral.

Have you tried powering from the power supply first and then attaching the usb?


#3

I’ve tried power first, USB first, waiting etc. all with the same result, no USB connection. Also tried using my Hydra as well (interesting however with power attached the green LED started flashing on the mainboard)

I could try higher voltages etc as I have a drawer or two full of power supplies. Just tried 16v at 1A and same results.

Thanks


#4

That is interesting that the Cerberus seems to be working as expected (ie remains connected with power attached). NOTE I haven’t done anything with or too the Cerberus since I received it so its still running 4.2 and the Mar 2nd build (410462).