Main Site Documentation

Panda vs. Mac


#1

I just bought a FEZ Panda. I went to download all the stuff to program it and it seems to run exclusively on Windows. I have a Mac. I know there’s a way to run Windows on Mac, but I’d rather not. Isn’t there a way to make the Panda talk to my Mac?

Thanks, Grant


#2

Support for MF is not available on the Mac.

On a Mac you will have to run Fusion or Parallel.


#3

Has anyone gotten this to work running in Parallels? I’ve tried, and I’m able to use MFDeploy to ping the board, but when I try to deploy the project in Visual Studio, I get a fairly generic error that didn’t give me any clues. Something like “Please check the hardware” (I’m not at home right now so I can’t get details).


#4

peddy, this doesn’t directly answer you, but it is something else to try if Parallels doesn’t work.

I got windows xp running on my mac using bootcamp, which ships with osx 10.6 and later. I got tied up with work at that point so I didn’t get the sdk running yet, but windows seems to run normally on the mac this way.

Grant


#5

I have not run the SDK under Fusion or Parallels on the Mac, but I have run it under VMWare Workstation 7 on a Vista machine. It worked fine.

*** Are you sure that the software on the Panda is at the same level as the SDK?


#6

I did verify the software on the Panda is the same level as the SDK.

I have not tried using BootCamp yet. The only setup I’ve tried so far is Windows 7 running on Parallels. I also have Fusion installed. Maybe I’ll try that and BootCamp and see if there’s any difference.

Thanks,
Paul


#7

I can’t be sure of the specifics but someone else here posted about making sure you use “full pass thru” or similar of USB devices. The scenario was the reboot during deploy meant that a connected USB device became “disconnected” and didn’t show up on the windows machine and therefore VS timed out.


#8

Just got done installing all the software in a Fusion virtual machine (running Windows 7). I was able to get my project deployed and running.

As mentioned by Brett, I did see the USB device disconnect when it was rebooted by Visual Studio, but Fusion has a nice little icon that allows you to manually reconnect the device, so you don’t get the timeout.

Still not positive if that’s truly the issue in Parallels (as my error happens immediately… doesn’t seem to go through a timeout). But just wanted to report my findings with Fusion.


One other thing I just noticed in Fusion. You can tell it to automatically connect the GHI USBizi to Windows, and then you don’t have to worry about doing it manually.

I tried doing the same thing in Parallels, but still haven’t had any luck.

For now, it looks like everything is working great with Fusion.