Main Site Documentation

Panda II - SD not formatted problem


#1

Hi there,

I have inserted a Micro SD card into my Panda II and have tried the tutorial code to list out the files/folders etc.

The problem I have is that the SD card is ALWAYS seen as not formatted (i.e. VolumeInfo.GetVolumes()[0].IsFormatted always returns false) - I have re-formatted the SD card as FAT and Fat 32 and also tried a different SD card - no joy.

The card is being mounted and it even has the RootDirectory property populated… of course if I ignore the IsFormatted property and continue anyway, I get a System.NotSupportedException when trying to list the files…

The MicroSD socket is inluded on the Panda II board so it cannot be a wiring/soldering issue (unless the board is faulty)

I am powering this from a USB port at the moment but as there is NO other circuirty attached to the baord the power should not be an issue.

Any ideas would be appreciated

Thanks


#2

try another powersource anyway. There are SD cards that can draw allot of current which the usb port can’t handle.


#3

And with some type of cards, you may need to add some capacitors to your panda II ???
See this Thread: http://www.tinyclr.com/forum/2/3277/


#4

Thanks a million for the replies guys…

I have tried adding a power supply but still no luck, still have the same issue.

I read the thread concerning soldering extra caps onto the board, I think this may be my answer as my board also reboots when inserting or ejecting cards, I will dig out some caps and the soldering iron and see if this helps.

Thanks again for your help…

Any GHI guys out there…

It is a bit dissapointed that this does not work out of the box as the onboard SD is one of the reasons I chose the Panda II for my project in the 1st place, should I end up needing the Panda II in any volume I cannot hardware hack every one of them, it also it seems that different caps may be needed depending on the SD card I use, this may be a problem as I cannot be sure what make of SD cards will be used in the end product - any of the GHI techies have any ideas on this one?

Thanks


#5

What type of sd card are you using?
Did you try a completely different bard? Maybe a faulty Panda?

You can mail us the SD card to test here.


#6

Thanks for the quick reply Mike…

I have tried it using 3 different SD cards:

2gb Sandisk
8gb Samsung
32gb Lexar (Class 10)

Yep I can easily mail a SD card in for a test… it may take a little while as I am based in London…

Not tried it with another Panda II as I have not got another board handy at the moment… I will order a few more and give it a test… (I will need more anyway as I have to submit one to the customer as part of my prototype, once working of course)

Christo
London


#7

If none of these SD cards are working then there might be something wrong with the Panda you have. It is better to test on another Panda board.


#8

Hi,

My new Panda II board arrived yesterday and I re-ran the code, worked first time which points to the 1st Panda being faulty…

The board still reboots on SD card insert but I will try with an external PSU tonight.

At least the file system on the card is accesible now and I can log data, I am not sure how to correct it on the 1st board though.

Thanks for all the help…


#9

So you have 2 FEZ Panda II boards, one works fine and the other works but the SD card on it doesn’t work?

Where did you buy your FEZ?


#10

Hi Gus,

Yes that’s right… the first Panada II board, purchased from coolcomponents.co.uk did not want to recognise any SD card as being formatted (hence me starting this post) as can be seen above, Mike suggested the Panda II board may be faulty… I purchased another, this time from another supplier here in the UK, proto-pic.co.uk (I needed some other components from them at te time)

The only other difference I can think of is that I have not yet updated the firmware on the new board, in fact I have not even checked whether it needs updating, I just unboxed it and tried the SD card code last night. I definitely updated the first boards firmware though.

I can double check the two boards for firmware versions but doubt the latest update would have caused it.

Perhaps I should pull out the old monacle magnifier and see if I can spot any bad track connections on board no 1


#11

Yes please check that both have the same exact firmware and also check the connections on the micro SD connector and around the processor


#12

Firmware is always the first update you need to do. If you don’t and you have a mismatch, then you deploy a program to it, you can get yourself into more confusion. Step 2 in unboxing should always be update the firmware :slight_smile:


#13

Thanks Brett, yep agreed, a firmware update is nomally my first check.

As it turns out the firmware is identical and up to date on both boards (as I suspected) I did not think that the SD card would work with an OLDER version of the firmware and not with the new.

So… the two boards are definitely both at 4.1.5.1 - one works 100% one does not.

I checked the solder connections on the SD socket and the USBizi chip with an eyepiece but cannot see any bad connections. The internal connaction pins inside the socket look fine as well.

Back to square 1, outta ideas


#14

You can always return to GHI for free replacement, you still have to cover shipping charges. Email GHI directly and explain how you like this resolved. They may have other options for you.