Main Site Documentation

Panda II and desktop USB issues


#1

Hey forum,

I got some issues recently with my Fez Panda II and the desktop computer I’m using.
When I connected the board and tried to ping / firmware version it from USBizi updater No connection kept showing up, and the updater froze. I tried a few times to wait, and after a couple of minutes the log showed No response from device. When I disconnected the board updater responded again displaying an error message.
However, the board is working just fine on my laptop.

The desktop was getting slow at start up in addition, so I formatted and reinstalled windows (with drivers, SDK, etc) to see if this solved anything, which it didn’t.
Works wonders on the laptop, but the desktop gets issues again. Updater freezing, USB drivers not working/found. I tried to navigate to the driver manually but no luck.

Under device manager (after reinstall of windows) I see GHI .NET Micro Framework USB Debugging Interface, like I should (right?), but with a yellow triangle and device properties displays

Device status
This device cannot start. (Code 10)

I’m not sure what it is, but a week or two back one of the USB ports I had got removed the plate separating the pins in that port. It is possible that V+ got connected with D- (bent pins). Could this be an issue?

I’ve tried several USB ports on the desktop, same result on all. USB HDDs, keyboard and mouse works though, with the exception of the keyboard losing connection (after reinstall), but that hasn’t occured relatively recently.

Hope you can help me with diagnostics

EDIT: Tried to install drivers (first time after reinstall) for my Arduino Mega as well, which seem to work just fine. Same USB port as used for the Panda.
I don’t think it’s my mother board after all.

On forehand, thanks
Aleksander


#2

What are the speed of your desktop and laptop?
What operating system are running on each?
Do you have any virtualization software installed?
What version of the firmware have you installed.


#3

I would use powered hub or power pack and then restart your pc.


#4

Hey Mike,

Both computers run windows 7, with no special vizualization softwares running, besides JVM, which runs on both computers.

If by speed you mean the specs, desktop / laptop
6 gigs RAM / 4 gigs RAM
Intel i7 930 2.80 GHz, not overclocked / AMD Athlon X2 2.0 GHz
64 bit OS / 64 bit OS

The Panda II firmware is 4.1.8.0

Sorry I forgot to mention this


#5

Think you solved it, Gus.

I unplugged the other devices using USB ports(as I don’t have a powered hub at the moment), besides keyboard and mouse. Driver installation went smooth and Updater has communication.

Thanks to both of you =)