Main Site Documentation

Panda II An4 fails under load


#1

I am using An4 and An5 with identical code (other than port number) and with no load both hold voltage correctly at 3.335 volts. When connected to the positive terminals of a LAA110 (http://www.clare.com/home/pdfs.nsf/www/Laa110.pdf/$file/Laa110.pdf) An5 works fine, but An4 only holds 3.335 for about .25 seconds and then drops to 1.332 volts for the remainder of the 5 seconds I have it set to true. I have swapped the connections of the An4 & An5 to swap which switch they are driving and I get the same results with An4 not holding voltage. I have changed the LAA110 completely and tried 2 different Panda IIs.

Can anyone provide me any input into why this is happening?

Button1 = new OutputPort((Cpu.Pin)FEZ_Pin.Digital.An4, false);
Button2 = new OutputPort((Cpu.Pin)FEZ_Pin.Digital.An5, false);
Button1.Write(true);
Button2.Write(true);
long end = DateTime.Now.Ticks + Milliseconds * 10000;
while (DateTime.Now.Ticks < end) { }
Button1.Write(false);
Button2.Write(false);


#2

Hello

Could you clarify how you have connected the LAA110 to the An4/An5 ?
Have you connected it straight to the pin ?

In that case it is normal that you get voltage falling to 1.3V.

This is a LED with a typical dropout out voltage of 1.2V and command current of 5mA. [see datasheet page 2 “Input characteristics”]
So when current flows, you will get ~1.2V on the LED, ie also on the pin.
AFAIK the current output capability of USBizi is 4mA (from NXP datasheet as I was not able to find it in USBizi doc). So you are on the limit and will not destroy the LED but the USBizi pin may suffer.

You need to add a resistor of (3.3V-1.2V/0.004A = 525 Ohms

Sorry if my assumptions are wrong and you already have the resistor.


#3

I do have it connected straight to the pin, though I am confused as to why it is working on An5 but not An4. I will try adding the resistor to see if that helps.


#4

Try to use only An4 without An5. Is the result the same?


#5

Maybe you overloaded the pin that caused internal damage?


#6

Using them individually has the same results.

I’ve tried it on 2 different Panda IIs and with no load it goes to 3.335 and holds, but with load it goes up to 3.335 for somewhere between 0.25 and 0.5 seconds and then it drops down.


#7

I don’t understand too why you have a different behavior between An4 and An5.
May be there is a connection issue somewhere ?
When you set An5 up and it stays at 3.3V, does it close the relay ?

However, the datasheet is clear : this is an optical relay that should be driven like a LED.


#8

An5 does close the relay, An4 does not. I will try the recommended resistor later when i have a chance to get my soldering iron out.


#9

Hello PintSize.Me,

Any update ?


#10

The resister did not help, if I can figure out how to read the specs on transistors I plan to try using An5 to control the transistor, and use the transistor to control the relay.