Main Site Documentation

Panda and Arduino ethernet shield


#1

Hi,

Im new to FEZ panda. I have a FEZ panda and a Arduino ethernet shield. But i can’t get my ethernet shield online.
I have tried with a static ip, and a dhcp configuation and i have used wireshark to see any network traffic from it… But nothing happens… Even not arp packes can i see in wireshark with it.

And there are light on 100M led, and link LED, and sometimes RX led is blinking…

I use the following code in VS2010:

using System;
using System.Threading;

using Microsoft.SPOT;
using Microsoft.SPOT.Hardware;
using GHIElectronics.NETMF.Net;
using GHIElectronics.NETMF.Net.Sockets;
using GHIElectronics.NETMF.Net.NetworkInformation;
using System.Text;
using Socket = GHIElectronics.NETMF.Net.Sockets.Socket;

using GHIElectronics.NETMF.FEZ;

namespace FEZ_Panda_Application7
{
public class Program
{

    public static void Main()
    {
        
        try
        {
            byte[] ip = { 192, 168, 5, 25 };
            byte[] subnet = { 255, 255, 255, 0 };
            byte[] gateway = { 192, 168, 5, 1 };
            byte[] mac = { 0x00, 0x88, 0x98, 0x90, 0xD4, 0xE0 };
            WIZnet_W5100.Enable(SPI.SPI_module.SPI1, (Cpu.Pin)FEZ_Pin.Digital.Di10, (Cpu.Pin)FEZ_Pin.Digital.Di9, true); // I have tried with Di7, and Di9.. 

NetworkInterface.EnableStaticIP(ip, subnet, gateway, mac);
NetworkInterface.EnableStaticDns(new byte[] { 192, 168, 5, 1 });

//Dhcp.EnableDhcp(mac, “smgethernet”); // I have also tried to use this without the static ip settings…

}

        catch (Exception)
        {
            Debug.Print("fail");
            
        }     
  
 
        
        

    }




}

}

I hope you can tell me what i’m doing wrong here…


#2

Hello !

Arduino ethernet shields needs a little modification to work with Fez :

http://wiki.tinyclr.com/index.php?title=FEZ_and_Arduino_Ethernet_Shield_05

And please tag your code to make it readable in the forum (“Button 101010” when you write a message…).

Good luck !
:slight_smile:


#3

Thanks… It working now :smiley: