OSHW Firmware on custom STM32F4 base board : How to deploy Hex Files using the SWG Interface provided by the Discovery?

@ Justin -

Created from the Cerberus !

The problem is there :

    <Directory Id='TARGETDIR' Name='SourceDir'>
      <Merge Id="id_msm" Language="1033" SourceFile="$(var.BinPath)\..\Installer\$(var.SafeProjectName).msm" DiskId="1" />

SafeProjectName is not declared in common.wxi, but if I create the define with my board project name, it says that it already exists with FEZCerberus…but where ?

Personally i would create a new solution from scratch - it’s pretty easy…
Sorry cant be of more help.

@ Justin -

OK, Done from the template and now OK… :clap:

@ LouisCpro - excellent :slight_smile:

Look forward to the video / write up :wink:

@ Justin -

Have to do all about my modules now !

@ LouisCpro - Good stuff :slight_smile:

@ Justin - Thanks to you all !

Hi All,

Can someone tell me in the Gadgeteer Designer, what is the ratio to convert from the left/right XML coordinates, to the width/heigth of the bitmap ?

It would be simplier to know instead of a dicotomic search :slight_smile:

Thanks !

@ LouisCpro - they are all in mm

Make your image say 1000 pixels wide or high

and if your socket is 4mm in from the left then use 4

There is no relation to size of bitmap. The relation is between the defined module size and the left/top coordinates.

So If your module is 100mm x 100mm meter big, then set the module size to that.

Then the left/top coordinates are all in mm…

Thanks both, this is clear !

Thanks to All for your help during this week, to achieve my first Home made Gadgeteer Kit ! see Attachment…

I recognize that the graphic representation is not really nice, but the profit is that IT IS WORKING !!!

I will publish a video next week to show you in practice !


Excellent work :slight_smile:

Very cool!

Hi All,

I was happy to show you a video this morning with the running box, but something strange appeared as I started the box… 3 of my 12 inputs do not respond anymore to the interrupt, as I did no change til friday…

Very strange ! However I tried to reboot, reinstall the discovery firmware and so on…Nothing ! Always the same 3 inputs do not fire the Interrupt event !

Than it sounds for me like another doubt on how it is implemented between the firmware and the gadgeteer libs…

I tried to reload the Gadgeteer Cerberus firmware the Jay made for me, but it crahes on I2C access, or even input definitions…Dont understand why !

I’m going MAD !

Another strange thing !!!

Look at this thread : http://www.tinyclr.com/forum/topic?id=10680

I finally found what cause the interrupt to fail on certain inputs ! => the RS232 !!

What is the link between them ???