OMG I did it

Took a few attempts, but the result is sooooooooooo pleasing :slight_smile:

4 Likes

I have that on my short list of things to do/try. It would be a BIG help if you could post the procedure you used and the problems you found.

Also, what is needed in addition to VS2015 CTP?

Me too ;D

@ Mike

You need:

  • Windows 10 running on Hardware.

  • Sd-Card Reader.

  • Download Pi2 Windows Core Image.

Read this website:
http://ms-iot.github.io/content/win10/SetupRPI.htm

Install Image und wait…wait…bluescreen (MinWin)…Startscreen.

Finished.

Install VS 2015 RC on Windows 10(in work…)

Start Develop (Tomorrow…)

@ Mike - It is generally recommended to uninstall 2015 CTP. You need 2015 RC, which came out just today.

I’ve tried several times on Windows 8/10 machines, and in all cases I got an "Windows 10 SDK 10.0.10069 : The installer failed. User cancelled installation. Error code: -2147023294 " error just at the end of VS 2015 RC installation. Without that SDK, you can’t compile Universal App.

Finally, I have it working on Windows 8.1.

  1. Follow instructions here http://ms-iot.github.io/content/win10/SetupRPI.htm of how to prepare your RPi.
  2. Then, follow instructions here http://ms-iot.github.io/content/win10/SetupPC.htm of how to setup your PC. If you get the error described above, pay attention to the paragraph telling to install “Standalone Windows 10 SDK for Windows 10”. (it also says to install “Microsoft Windows 10 Emulator for Mobile”, but I found that not necessary to debug directly on RPi). Also, it is not necessary to have Windows 10 installed. I do it on Win 8.1.
  3. It is also easy to miss instruction of how to tweak policies: Enable your device for development - Windows apps | Microsoft Learn
  4. Should be good now. Try HelloWorld! http://ms-iot.github.io/content/win10/samples/HelloWorld.htm

Is the version of .NET that runs on the PI the full set, or the “Universal App” subset?

@ Mike - Universal apps only, to my knowledge.

Perhaps once he’s caught his breath from BUILD, Pete can comment further.

Yup, Universal App only, or at least I can’t find anything else. Lots of API changes, I’d even say a massive API change. Still can’t find how to write to a file, looks like it is not implemented yet…

But all the Networking, Tasks and Generics are here!

@ Simon from Vilnius - Since VS2015 is a RC, I would expect all of the Universal API stuff would already be there?

For some embedded applications, a GUI is not needed. I guess if not sees it, a Universal App GUI is ok if it is blank.

@ Mike - VS2015 is RC, that’s true, but Windows 10 IoT and Universal App is still far from RC, I think. I believe still lots of things are to come to RPi 2 and Windows 10.

I took a look at the UAP classes related to the device namespace with reflector. From what (little) I know it’s all there, but is 95% stubs. Once I get the RC installed I’ll see if anything has been updated/added. Hopefully at least the documentation has been included.

It’s open source… the community needs to write the actual functions now.
Don’t be lazy, jeez. :slight_smile:

(j/k)

For what it is worth, it worked for me on using a VM hosted in VMWare. It won’t work with Hyper-V because Hyper-V can’t redirect the SD card reader correctly, but in VMWare, just connect your SD card reader to the VM using the VM->Removable Devices menu and it works just fine. I was able to install the environment, flash the SD, and deploy and debug all from within two separate VMWare images.

When you enable ‘universal apps’ in the VS2015 install, be sure to dis-able the Mobile Emulator option. That wants to start Hyper-V within your VMWare image, which can be done, but adds a whole additional layer of complexity and is deathly slow. If you are going to run the virtualized phone emulators, then yes, you probably should use raw hardware as your OS host.

I had all the same issues previously reported in this thread and haven’t found anyone yet that didn’t. You basically have to install the SDK separately before you can successfully build or deploy. Not sure how that one slipped through, but it’s early days I guess.

So, everything working - but the lack of support for wifi and BLE dongles is going to crimp my style for a while.

Lol

I was trying to use VS 2015 CTP

No wonder I was having difficulties.

I am downloading VS 2015 RC Professional, now.

I am assuming that the PRO version will work… I didn’t want to install the express or community versions, nor the “enterprise” version.

This is a little convoluted to get to, but here’s the link to the full readme for this release : https://go.microsoft.com/fwlink/p/?LinkID=529194

Lots of relevant stuff in there especially regarding GPIO issues.

I got it to work :slight_smile:

I compiled and deployed the example “hello world” app from VS 2015 rc.

This is awesomesauce.

I’m using Windows 10 10074 on my desktop. No Issues.

Edit: I shouldnt say [em]no [/em]issues.

I had to change my wireless network connect from “Public” to “Private” with secpol.msc
And edit the group policies with gpedit.msc
…But those steps were documented in the tutorials I used.

shurely the community edition is good enough, as long as its the 2015 rc release a couple of days ago,

Got my RasPi 2 running Win10!! Thanks for the links. :smiley:

Universal Windows Apps with the IoT additions.

Pete

I think that may be reflector failing you. It’s mostly implemented, but there are a number of bugs. I’ve been using GPIO and similar for a while. I haven’t checked our build release, but to the best of my knowledge, uart/serial, bluetooth, and wifi are the big missing pieces. Quite a bit of the rest works well.

Pete