NotSupportedException rlp


I just received a unlock code for rlp and pasted it in the RLP_Starter_Example code found on the wiki page “RLP getting started”.
When I try to run the managed code I get an error NotSupportedException on the rlp unlock function.

Any idea what goes wrong?


If you use Firmware 4.2.x you don’t need to unlock it anymore.
Haven’t tried so far, but this is what Gus told me.

Hi Reinhard,

Thanks for the response.
I’ve tried NETMF 4.2 but I got the same error now on the LoadELF function.


What device?

HI Gus,


It should work, no unlocking required.

Where did you read about unlocking?

Welcome to the community.


There was a remark about unlocking RLP on the wiki page (RLP Getting Started). Since I’m using the example (RLP_Starter_Example) mentioned on that page I thought it would be necessary to get an unlock code.
Using Netmf 4.2 unlocking doesn’t seem necessary but I’m still getting this error System.NotSupportedException on the RLP.LoadELF(elf_file); line.


I updated the wiki page, thanks for pointing it out.

Now, can you try other methods in GHI libs to make sure you are able to use any of the libs? Did you make sure you have the latest SDK and updated the firmware?


I’ve added reference GHI.OSHW.Hardware and the line

int t = GHI.OSHW.Hardware.RTC.GetTime().Hour;

before calling LoadELF.
Now the error System.NotSupportedException occurs when calling GetTime


[em]I’ve added reference GHI.OSHW.Hardware and the line[/em]

If you are using an EMX then you should be using the Premium library. The references begin with GHI.Premium.


OK, but where in the Premium lib can I find the gettime function?


Wrong lib, please see

Hi Andre,

I’m not perticularly focusing on the gettime function but Gus or Mike asked me to try another GHI specific function.

So this time I’ve changed to:

int t = GHI.Premium.Hardware.RealTimeClock.GetTime().Hour;

but still the same error.


We were not telling you to use another function. We were telling you add the correct reference to your project and namespace to your program.

Check this page for the 4.2 GHI Premium Library documentation.

The RTC is hardware, which should help you find the support for the RTC.

Please make a new solution and add a simple line of code and show us the code. and show snapshot of what libs you have added.

I think I found the the problem:
I tried to run the example in the emulator. Apparantly this is not possible.
Now I’m running it on my device (EMX) and that seems to be working.