Main Site Documentation

Not updating


#1

So I pulled my FEZ Spider 1.0 out of my closet today to do some experimenting again. As things would have it, I have the 4.2 framework on my computer (VS 2012) and my board is still at 4.1.6.0. I’ve been trying to update it with the updating tool, but the signature checks for config and firmware both fail, and firmware2 stops writing every time at 0x800bfc00 and encounters an error. I’ve tried external power, flipping switches, but to no avail. currently, there is NO firmware in the device, the tinybooter is at 4160, and all my switches are set to [up].


#2

Yes welcome to the forum. As you’ve identified, you need to get the firmware installed. That’s not something that should be a problem, even if you go back to using the manual instructions https://www.ghielectronics.com/docs/54/firmware-update-emx


#3

https://www.ghielectronics.com/docs/54/firmware-update-emx is the one i’m using, with the first option of the auto-updater. I tried the manual as well, but I can’t seem to get that working either.


#4

Can you tell us what you see in Device Manager when you boot in loader mode? And tell us about what the fault/s or error/s are, that might help pinpoint how to approach this.


#5

@ brett I set it up USB loader mode, switches 1-3 are on and 4 is off (or when read with the reset button at the top, off on on on.) windows makes a popup about an unrecognized device.
location = Port_#0001.Hub_#0004
stopped device due to code 43 problems

the screen on my device is blank white as well.

@ andre.m I do not have that folder.


#6

Unrecognised device means the driver isn’t loaded properly.

Given that, can you tell us what appears in DevMgr when it’s in normal mode not loader mode?

Onto the drivers, you might need to manually uninstall the GHI drivers (remember to select remove the files) and then reinstall from your SDK installer


#7

What Operating System and USB connectivity are you using?


#8

@ andre I did.

@ brett Debuggable .net micro framework device>ghi .net micro framework usb debugging interface
so I have to uninstall ghi from my computer, reinstall ghi, and then reinstall the firmware?

@ hector Windows 8 Normal (not pro) 64-bit USB 2.0


#9

Can’t hurt to uninstall and reinstall it…

(BTW I use a Cobra, based on EMX, on a Win8 Enterprise x64 with USB2 ports so your configuration is not that unusual )