Main Site Documentation

No virtual serial (com) port after Fez domino is connected


#1

I have just recieved my fez domino and installed all the required downloads. Following the instructions, It seems that I need to update the firmware. MFDeploy picks up my device and I can Ping it and also get the device information.

ClrInfo.clrVersion: 4.1.2821.0
ClrInfo.clrVendorInfo: Microsoft Copyright © Microsoft Corporation. All rig
ClrInfo.targetFrameworkVersion: 4.1.2821.0

Basically following the tutorial is easy, the problem comes with the com port. The problem being that there is no serial ports on my machine :slight_smile:

I can’t see any under device manager nor can I see anything under TeraTerm of MFDeploy.

What I have tried:

  • I have installed and uninstalled the 64bit driver multiple times with no success.
  • Tried on another machine. Same problem (Both machines are 64 bit Windows 7)
  • Tried loading the 32 bit version but it fails to install
  • And obvoiusly I have restarted my machine a few times

Any ideas?


#2

Does this help http://www.youtube.com/watch?v=a3N0nQRWb08


#3

This is what I am trying to follow but in the tera term I need to connect to the serial port. But on my machine(s) there are no com ports listed.


#4

Did you hold the LDR button the reset while keep on holding the LDR button? Then does windows ask for drivers? What do you see the your PC’s device manager?


#5

So I did that, It automatically installed the driver (GHI Boot loader … ) for me and I got a new COM3 port open. I followed the rest of the instructions and it all went smoothly. Though I still do not have a serial communication after the update.

In device manager I have no serial ports. Only after pressing the LDR button does the following appear (See image)

I’m happy that the firmware is now up to date (i think). But I guess I still need that COM port for serial communication in the future, Right?


#6

No, the serial is only there for firmware update and then it is a NETMF debug interface. But you can change it at runtime (only on GHI boards) to be a CDC device (serial)


#7

Thanks Gus. I was able to deploy my first little program and it seems to work. I’m still not sure why that initial serial device did not register. But hey … if it works it works.

Thanks Again. (Amazing support in 1 hour)