Main Site Documentation

No debugging message shown in output window


#1

Dear All,

I have a platform that runs USBizi (NXP LPC2388). Sometime debugging messages are not shown in the output windows after I deploy and run the program through Visual Studio. After I press F5 (strat debugging), it shows “Rebooting…”. After two or three seconds, it shows 'Done." Then nothing happens. It seems that the board is dead, and has no any debugging messages sent back to Visual Studio. This condition does not happen all the time. In some time, the board sends debugging messages normally, and everything works very well.

I am using GHI NETMF SDK v4.1.8.0. The processor on my platform is the same one on FEZ Domino. I tried the same program on FEZ Domino and gets the same problem.

The libs I am using in my program are:

using System;
using Microsoft.SPOT;
using System.IO.Ports;
using System.Text;
using System.Threading;
using GHIElectronics.NETMF.Native;

Greatly appreciate for any clue on this problem!! I searched previous discussion. It seems that other buddies met the problem before and fixed it by updating firmware. However, I am using a very new firmware v4.1.8.0.

Thanks a lot,

Best wishes,

Frankcmu


#2

Yunlin, the typical issue that causes the deploy/debug to fail is related to your code. If there’s a tight loop that means no processing time is released, the debugger often can’t connect. There are possibly also timing peculiarities that can make this seem random.

When this happens, just hit RESET on your board again and things usually continue along as expected. When it next happens can you try this and see if it allows the process to complete?


#3

Hi Brett,

Thank you very much for your quick reply. My code will stop by waiting for incoming command from UART port (UART-related code is implemented by RLP). So it is reasonable that the program will get time to output debugging messages back to PC over USB. right? Except that I disable all interrupts in RLP.

Thanks again!

best wishes,

Yanlin


#4

One more details for my problem:

I am sure that the board is dead because the program I deploy and run the board is a serial communication code. If the program is running on the board, PC will be able to send/receive message to board over UART interface. Unfortunately PC cannot send or receive messages when the problem happens.

Greatly appreicate if anyone provide any other clue on this issue!

Thanks a lot,

Best wishes,

Yanlin


#5

sorry, I don’t understand your scenario very well.

Many people have mentioned minor deploy/debug pauses and a reset at that time allows the debugger to talk to the chip. Did that help you or not?


#6

Also, I don’t know what you mean “the board is dead”? Totally failed and never come back? Or just purely in a state where the debugger session isn’t talking?

That could imply that the app might have crashed and not recovered.


#7

Hi Brett,

Thanks a lot for your replies. ‘The board is dead’ means the system or my program is crash. To build a stable system, I cannot pass the problem by simply resetting the system.

Best wishes,

Yanlin


#8

Still struggling to understand what you want to achieve?

This only happens when you’re [italic]deploying [/italic]code in debug mode, right? Whats the issue in resetting it during this development activity?

Are you concerned that this is some issue that will affect your app when it’s in production? The only way to know that is to put your app and board in the release mode and have diagnostics come from it (not via debug)

Since your problem seems to be the same as what comes up here periodically, I assume you’re just hitting the same strange criteria that others do too - so it’s not something specific to you.