Main Site Documentation

Newbie problem with Cobra and 7


#1

hi guys

I am having some startup problems. When i start my module the display cycles through different colors. For a brief second it shows GHI logo and firmware status then jumps back to changing colors.

I have tried to use the example from the display. It compiles fine after removing error in font lines and then deploys without error. All i see on screen is chaning colors… bought 3 units and all does the same.

If i deploy graphical_demo to the board i can hear that it responds to touches on the screen but it is still just changing colors…

Thanks in advance for replys i am so eager to play with my new toys.

/Peter


#2

Have you upgraded the firmware & ghi .Net libraries to the latest version?


#3

Yes runnning on the newest firmware and code.


#4

Update Cobra once more using Tera Term and the firmware file available in SDK directory. Than I suggest you try this: open VS2010, create new project using Cobra template, deploy to device. Let us know if the effect still occurs.


#5

Is this the 7" display?
Have you tried to use powered hub or tried adding power to the board instead of relying on USB power?


#6

Hi guys

Thanks for the fast replys.

I have 2 identical setups one where i have unpacked a Fez Cobra and a 7" display where the cobra fits on the back. Both is running on 6V powersupply and i have checked that the power is steady at 6V.

This problem is straight from i unpack it, and attach the LCD cable and power on.

One i have firmware updated by using the great youtube guides. and then tried to load the graphical_demo in to it. I can hear that the touch responds to touch (Think i start a game) but the colors are still changing.
It looks like it is some kind of “screensaver” build in to the display. It goes from green -> red -> white -> B/W large checker -> b/w small checker. The delay between the color change is aprox 1-2 sec. BTW. the GHI logo only shows once on boot.

The color pattern might be a little different color wise it was just to give you an idea what happens. It looks like a program running not a faulty display.

Thanks in advance

Peter


#7

Looks like i solved the problem. The USB cable that came with the board was defective… Changes to another one now it seems to work.


#8

Glad it worked for you. Please let us know if there is anything we can do to assist further.


#9

I remember someone else also reporting on forum that USB cable that came with his FEZ was broken.