Main Site Documentation

Newbie help with Hydra and Cobra updates and getting started


#1

Yeah, my profile says “Master”, but that was a long time ago. I have been inactive for quite a while. I have a bunch of Gadgeteer boards and modules and pulled them out Saturday to get started again but I am stuck! I have searched the forumns and read the docs and tried to follow the wiki, but no luck getting started.

I have installed VS2012, the SDK, the latest netmf, etc. First step is always to update the firmware, right - especially if your boards are older and the sdk was released a few days ago.

When I plug in either my Hydra or my Cobra II, Windows sees them just fine. When I open up Fez Config, the one I have plugged in appears - but Ping says "Failure - Device is not connected or not responding. "

So, I followed the Wiki page for he Hydra and tried to deploy the sample project from VS. It sees the board connected, but says it can’t talk to it. So I tried a different usb port as suggested in a forum post. Same results.

I also tried to update the loader on the Cobra II and it fails - who knows what state it is in now.

Here is a thing: when the CobraII is plugged in, I hear the connect sound and see the device in the Control panel as G120. Aftr maybe 30 seconds, I hear a disconnect and then another connect. This repeats over and over. When I plug in the Hydra, it appears in the control panel device list as “Fez Hydra”. and I do NOT hear the repeated connect/disconnect. In the device list, the Hydra shows up as an "Unspecified"device type.

I have an i7 with 16GB ram and an SSD on Win 8.1. I am using the SDK posted Jan 30.

So, what can I try next - or did I try the wrong things to start with. To make it simple, let’s start by getting the Hydra to work - I will come back to the cobra after I get the Hydra to work.

Thanks very much for your help.


#2

This sounds familiar… I had the same behavior in the past.

https://www.ghielectronics.com/community/forum/topic?id=11293&page=2

For me this was related to power supply while flashing the device, going back to a older version and flash again with another power module fixed my problem at that time.

But the again… Gus told me it was impossible so maybe it was a coincidence…


#3

I am using an SP power module on the Hydra. The Cobra II I am just using USB Power. I will try external power on the Cobra.


#4

Now when I plug in the Cobra II, with or without external power, windows says it is an unrecognized device - until the self-reset it does after 30 seconds - then it is seen as a G120. Even with External power, the boards continues to connect/disconnect.


#5

the behavior is definitely the same as i experienced in the past, but this means Gus was right at that time… I’m not sure what else i tried at that time but one thing is sure, it’s solvable :slight_smile:


#6

I just tried a different cable - grasping at straws, but the Ping still does not communicate with the Hydra even though FEZ config initially sees it as a device.


#7

@ Blue Hair Bob - Are you able to update the firmware manually, or does the problem persist?


#8

Point me to the instructions to update manually and I will see. The doc I read said to just deploy from VS - OR use and SD card OR use another method by grounding pins. I will try anything - what steps should I try? Thanks for the help!


#9

Using MFDeploy, I can connect to the Hydra, but not Ping.

Connecting to FEZ Hydra_Gadgeteer…Connected
Pinging… NoConnection

Any ideas?


#10

OK, I tried option 1 of deploying via VS2012. No difference.
So, I connected a breadboard module to socket 14 and shorted pins 9 and 10 then reset. MFdeploy and Fez config still see a Hydra, but Ping says noConnection.


#11

I will take the board home and try a different computer tonight.


#12

I tried method 2 from the Hydra troubleshooting doc: put the breadboard module on socket 3 and ground pin 8, power up, wait 5 seconds, remove the jumper, reset, try to ping in MFDeploy - still no connection.


#13

I brought the Hydra home to try on a different machine. This one has the 4.2 SDK dated 10/23/2013 installed. V2013 R3 (v1.0.6).

It behaves the same way. I don’t seem to manually update the firmware. Ping won’t work. The device is seen by both windows and FEZ config (and MFdeploy), but cannot ping. Any other suggestions? I think I have tried everything documented. :wall:

Somehow, both my Hydra and my Cobra II seem to be bricks. In fact, the Cobra has the same constant connect/disconnect behavior as well.


#14

Can you show us a screen shot of your device manager driver details? Can you also put cobra2 into bootloader mode to see the driver it uses? I’d also do manual bootloader update and confirm that it stays up and stable with just that, not the firmware.


#15

Brett, here is the driver details for the Hydra.


#16

And here are the Cobra II drivers in Bootloader mode


#17

OK, I was able to get the Tiny Booter and Firmware updated on the Cobra II using Fez Config. Now Ping says “TinyCLR”. That’s progress. So the Cobra II seems to be OK for now.

I still need to make some progress on the Hydra.


#18

SUCCESS! OK, it is apparent now that I had never been able to get either of the boards into bootloader mode before. I think that the wire I was using might not have been a proper gauge for the pins. I used a breadboard jumper wire and it did the trick. Once I was actually in bootloader mode, the manual update worked on both boards.

I now have 4.2.6.1 firmware loader on the Hydra and the Cobra II. I should be good to go from here.

So, if you are in bootloader mode, Windows HAS TO assign a com port. If not, you are NOT in loader mode.

Thanks so much. I think I will mark Brett’s reply as the preferred solution, just because it pushed me in the right direction. :slight_smile:


#19

And the connect/disconnect loop on the Cobra seems to be gone as well.


#20

This morning I took both boards to the machine with the latest SDK and both updated fine. I am back on track.