Main Site Documentation

New Spider Not Recognized on USB. Tried just about everything


#1

I went through the install process on my new FEZ Spider today, including updating the firmware when prompted.

Neither the deployment tool nor Visual Studio see the spider. I’ve tried a number of things:

[ulist]I’m using a powered hub. The spider lights up fine on USB power.
Just in case, I plugged in a 9v supply directly to the spider. The spider lights up fine when using just that as well
I’ve tried different cables
I’ve tried different hub ports (all of which work with my Panda and Netduino)
I’ve tried switching between my two different powered hubs, and also powered down other USB-powered peripherals
I’ve unplugged and reseated the cables (I saw that worked for one person here)
I’ve completely unplugged and removed all power from the device, then plugged it back in[/ulist]

Whenever I change ports, Windows 7 x64 installs a new device (as expected). However, it indicates it is installing it on a COM port (it increments each time) as “USB Boot Loader Interface (COMn)” (I’m up to COM8). Is that normal?

COM8 shows up in MFDeploy (bit a ping to that fails), and the USB entry is blank.

I set the DIP switches all to up (Off) as that seems correct. I can’t be sure, though, as there’s no documentation I’ve found that explains when I need default vs. loader vs. tinybooter, other than the install instructions telling me to switch it over to the loader mode. Changing to different switch configs didn’t seem to have any impact.

I’m most of the way through a blog post on my initial experience with the spider, but am completely stuck at this point :stuck_out_tongue:

Pete


#2

You somewhat posted the answer :slight_smile: it is showing the "loader@ drivers because your spider is not running the firmware. And correct, VS will not see it.

The reason is one of 2 things, the config jumpers are all on instead of off or it failed loading the firmware.

Let us start with first possibility, are you positive the config switched are in off position? Only connect spider and red power module for now and plug into a pc.

If all is well, try to load the firmware again.


#3

Forgot to say, welcome toe the community :slight_smile:


#4

Thanks Gus

Ok, went to install the firmware again. The updater came back with a message saying it failed and I need to start over. MFDeploy now finds EMX_EMX as a device.

Repeated the process and it worked this time, telling me to reset the pins to default. I didn’t see that the first time around, so I must have clicked through a “fail”

So, two fails and a success and one person who missed the fail message the first time :slight_smile:

It shows up in MFDeploy now. Any idea why it would have failed that first couple times?

Pete


#5

Should never fail, FEZ Spider is perfect :slight_smile: I am kidding.

It is probably related to not having a reliable power source, as explained here http://wiki.tinyclr.com/index.php?title=Gadgeteer


#6

Thanks for the help.

Blog post:
http://bit.ly/uXEqzE

Pete


#7

Love it and tweeted it!


#8

Very nice blog Pete! :slight_smile:

I would like to pay your attention to an subject about .NET Gadgeteer that you can mention in your future blogs.
.NET Gadgeteer compatible socket types. .NET Gadgeteer Module Builder’s Guide explains this topic thoroughly:
http://gadgeteer.codeplex.com/releases/view/72208#DownloadId=273356

This helps the user understand what modules can work with what mainboard.


#9

Thanks Joe

Yes, I’ve read that document. I found the socket type stuff somewhat confusing at first, so I’m thinking about other ways to work it into my blog series without presenting a giant table to folks new to this area.

Incidentally, can you say who manufactures your sockets? My usual sources (Mouser) have turned up empty when trying to order them. I know you all have them for sale as well. The ones described in the doc are somewhat expensive and have to be imported from AU, as I recall.

Pete


#10

We purchase these sockets in high volume, that’s why it is somehow feasible for us. I am not sure where the guys get them from. Most likely they are from China.


#11

I got 10 socket samples from SAMTEC for free. Part # SHF-105-01-L-D-XX, where XX is below. Not sure what minimum order volume is, but I got the impression it would be ‘in bulk’ from the site.

TH for the through hole version.
SM for surface mount,
RA for right angle.

They even paid for super fast shipping from someplace in the US. I got them next day!

http://www.samtec.com/ProductInformation/TechnicalSpecifications/Overview.aspx?series=SHF


#12

@ Joe, thanks
@ Ransomhall

Excellent! I’ve been knocking around putting together a DIY kit and the through hole version is so much friendlier than the SM. Thanks for the info.

Pete


#13

The TH version is not protoboard friendly, but they do have a datasheet for adding it to a PCB. Would be nice if someone could make these into an Eagle part (cough, cough). Guess I’ll ‘share the love’ and post this in a new thread.

A gadgeteer module DIY kit? Nice! Keep us posted.


#14

Buy something in x10000000… volume and you get to set prices :slight_smile:
Actually the bigger problem is in the cables nit connectors. Those cables are about $10 each at digikey. We have about 20 cables in the kit. Can you imagine if we paid $200 for cables for each kit :wall:

We literally spent months evaluating connectors/cables till we found ones with high quality and good price. The source is top secret! No I am kidding but the source is only good if you are buying hundreds of thousands.


#15

@ Gus

No doubt.

As to cables, I figure people will have a spare one kicking around, or can disconnect something (or I can tell them to order more from you). It’s the sockets that were driving me nuts.

Pete


#16

@ ransomhall

I figured they probably wouldn’t be the .1 type pins, not with a socket that small.

I had my own somewhat large board printed up at one point; I used designspark PCB to design it and pcb-pool to get it manufactured. Info here:
http://10rem.net/blog/2011/07/03/building-a-midi-thru-box-part-5-circuit-board-assembly-and-final-parts-list

last post in the series here:
http://10rem.net/blog/2011/09/10/building-a-midi-thru-box-part-7-multiplexing-buttons-with-the-netduino

Pete


#17

Here is my library. It will grow more with my future modules


#18

@ Architect - thanks!


#19

All modules from GHI will be release open source and they already include the sockets as well.


#20

Good to know Gus, thanks. It’s great that you guys are being so open.

For my question about sockets, I was talking about DIY projects that would be above and beyond GHI (and other) gadgeteer offerings.

Pete