New Spider Kit - White screen and failed firmware update

I must admit this is all rather new to me and I am by no means a hardware guy, but rather a C# WIndows developer. I thought it would neat to code on the micro framework.

I just purchased and received a Spider Starter Kit. I am running on Win 8 x64 (desktop) with USB 2.0.

  • I installed MIrosoft Visual C# Express 2010
  • I installed Microsoft .NET Micro Framework 4.2 QFE2 SDK
  • I installed all components of the GHI NETMF v4.2 and .NET Gadgeteer Package (except legacy USB)
  • the switches are set to off, on, on, on (Loader)
  • When I plug in my spider when it instructs me to do so to update the firmware, first of all the screen is white. Nothing other than white has ever displayed on the screen. (Note: I am powering the spider with a power pack) Secondly, the update seems to go through except when it gets to the part where it says “rebooting”… see below…

Connecting to the device…
FEZ Spider found at Port#: COM5
GHI Bootloader Version: 1.02

Device will be updated automatically! DO NOT disconnect or turn off the device!
Erase successful!
Updating TinyBooter. Please wait…
Update successful!
Disconnecting COM5

Then it says “Updating failed!”

What are my next steps? Is this thing bricked?


Welcome to the community. There is an SDK coming out tomorrow we highly recommend you use instead but for now, folow the bold note here to load the USB driver manually

This should help

I have already installed: C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\USB Drivers\GHI_NETMF_Interface\ghi_netmf_winusb.inf
as well as C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\USB Drivers\GHI_Bootloader_Interface\GHI_Bootloader_Interface.inf

The device is even showing up in device manager.

What SDK is this that is coming out tomorrow? Do you think it will resolve what I am experiencing?

Your device is showing as a COM port. This means you do not have any firmware on it or you did not put the switches back to default position.

you can try manual update The page is for EMX not exactly spider but it may help you understand.

OK… Followed the instructions … but I got the BL after sending the file via XMODEM.
Also, there are no USB devices listed in MFDeploy.

Then something is wrong, like power is not sufficient or the firmware file is corrupted…or you selected the wrong file.

Have you tried adding power pack? Or using powered hub?

C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\EMX\Firmware\TinyBooter\TinyBooter.GHI

Using a power pack
INPUT: 120V~60Hz 22W
Positive tip.

And using various pin positions (Loader, Tinybooter, default), it always shows up as COM5 in device mgr.

Yes that is normal as you have erased the device in last step. Try to load it again please. and try the updater application as well.

Are you using teraterm from our website?

Yes I used TeraTerm link from the EMX firmware update page (which is the same as the one you just posted). I will try the process again.
And hey I really appreciate the help!

Interesting… now teraterm cannot get connected to COM5.

“Cannot open COM5”…

disconnected everything, checked to be sure switches are at loader, reconnected everything… same error again.

And when I run the updater “Cannot connect to device! follow steps 1 to 2 or visit …”

Just plugged it into another USB port and its coming up as COM4. Now able to connect. very weird… i will continue to try to update again.

First attempt… upon XMODEM send, it seems to get stuck on first packet for about 30 seconds… then the transfer window closes and now it seems to be going crazy with a ton of BLs, with the odd “Erase all memory”, “Bad firmware”, “1.02”… it seems like its being sent random characters or something… I will disconnect and try again.

Second attempt… file transferred… but got a BL after it again.

Tried updater app… got to rebooting and then failed. I am beginning to think that something is not right here.

Tried another USB cable… unfortunately, same result.

Please uninstall everything GHI and reinstall.

In the past we’ve seen some people overwrite the firmware files with TeraTerm accidentally by using the wrong transfer direction; and you have to make sure you use the 1K option. By reinstalling the SDK you’ll get a nice fresh copy of the firmware files so you should be right to go then !

I will try this tonight. Although I am starting to feel like I have a DOA product.

I uninstalled all GHI software and reinstalled… I first tried the updater app… still failed at “rebooting”.

Tried the manual update and received the BL after the transfer.

What are my options here?

Please request for RMA on contact us page and mention thus thread and we asked you to do so, to speed the RMA process.