Main Site Documentation

New Raptor - error during external ram initialization?


#1

Booting up new Raptor for first time … little luck.

Have power plugged in to port 8. Power light comes on, on mainboard.

Tried multiple USB ports, 2.0 hubs, and other PC’s … none of which seemed to act as-if any USB device was being connected. (FWIW, same PC’s talk to a Spider with no issues.)

External power - no change.

Decided to see if I could update TinyBooter. Did the short the pins trick, and hit reset. that got me something … a USB device.

After a bit of futzing w/ run as administrator, etc … programG400 COM9 … updating will start and then fail. Log file says “Error during external ram initialization”. (Full log, below.)

Running out of troubleshooting ideas. :frowning:

Anything else to try, before concluding there’s an issue w/ the board?

Thanks

-I- Waiting …
-I- TCL platform : Windows NT
-I- SAM-BA 2.12 on : windows
current connection is \USBserial\COM9, \USBserial\COM9 to be matched
-I- Retrieved arguments from command line :
-I- argv 0 : \USBserial\COM9
-I- argv 1 : at91sam9g15-ek
-I- argv 2 : G400TinyBooter.tcl
-I- Connection : \USBserial\COM9 (target(comType) = 0)
-I- Board : at91sam9g15-ek
-I- Traces Level : 4
-I- target(handle) : 65105344
Read device Chip ID at 0xfffff240 — get 0x819a05a1
-I- Found processor : at91sam9g15 (Chip ID : 0x819a05a1)
sourcing device file C:/Program Files (x86)/GHI Electronics/GHI Premium NETMF v4.2 SDK/G400/Firmware/TinyBooter/sam-ba.exe/…/tcl_lib/devices/at91sam9g15.tcl
sourcing board description file C:/Program Files (x86)/GHI Electronics/GHI Premium NETMF v4.2 SDK/G400/Firmware/TinyBooter/sam-ba.exe/…/tcl_lib/at91sam9g15-ek/at91sam9g15-ek.tcl
-I- Loading applet applet-lowlevelinit-sam9g15.bin at address 0x300000
-I- Memory Size : 0x0 bytes
-I- Buffer address : 0x4
-I- Buffer size: 0x0 bytes
-I- Applet initialization done
-I- Low level initialized
-I- External RAM Settings : extRamVdd=0, extRamType=1, extRamDataBusWidth=32, extDDRamModel=0
-I- External RAM Settings : extRamVdd=0, extRamType=1, extRamDataBusWidth=32, extDDRamModel=0
-I- Loading applet applet-extram-sam9g15.bin at address 0x300000
-E- Error during external RAM initialization.
-E- External RAM access is required to run applets.
-E- Connection abort


#2

@ ZebTanner - Two questions for you:

  1. What are the specs of the external power supply are you using?
  2. When in normal mode, does anything show up in device manager?

#3

Hey James,

Thanks for the quick reply.

  1. Using a 12V, 1A adapter [Although same behavior with/without.]

  2. In normal mode, nothing at all shows up. [Same on 2 computers now, one Win 7, one Win 8 … both work with my Spider.]

FWIW, just one other observation … in normal mode … behavior following a reset or power-up is inconsistent.

  • Usually just red power light comes on.
  • Sometimes … after short pause, blue LED lights solid
  • Have once seen blue LED solid… blue LED flash … blue LED solid

No matter the lights … never have seen any USB device show up in normal boot mode.

As one more effort to isolate possible causes … tried swapping the power board, and cables w/ the ones that work w/ the spider. No change. Raptor fails in exactly the same way.


#4

@ ZebTanner - Please contact support via email with a description of your problems. We will get to work on an RMA as soon as you do. Sorry for any inconvenience this may have caused.


#5

Will do. Thx.