Main Site Documentation

New Hydra Kit + TE35


#1

Hi everybody,
I’ve been designated to finding a solution to getting a Hydra Kit we jsut received working at the company I work for.
Basically we are looking for a NETMF solution to replace/install around 50 devices. Anyways, we thought we would save some cash and get a Hydra instead of a Spider.
We received the Hydra around 6 hours ago. Boss had a look at all the stuff, plugged in the screen to the hydra (RGBT sockets), and then the usb client to the D socket.
Powered it on and the screen remained white. I’ve read around these forums and apparently some text or a picture of Stitch use to appear. Does that still happen or is a white display expected?

Installed VS 2010 (as we normally only use 2012 and 11), put on the .net drivers (both 4.2 eqf2 and 4.3), installed the packages listed in GHIs listing, and then after that we tried popping it into a usb port, with power running at around 480-490 ma.
Green light flicks for half a second, red light stays powered on.
The windows USB device sound flicks on and off every few seconds. Change the port to a different port, which outputs 500-520ma and it stops flicking on and off so no more annoying windows 8 sounds.
We hit update in the updater, say no to ethernet (as we didn’t bother buying an ENC28 adapter - so another reason we should have gone for the spider as usb client isn’t supported in the hydra as we only found out last night), and then let it go. It reports back that it was unable to connect to the device and no port was found.
However looking in device manager we have an enabled device “GHI.NET Micro Framework USB Debugging Interface” availabe. For hidden devices there is a COM4 GPS Camera Detect - however it always stays hidden (ie the device is never detected as active/connected).
We then uninstalled and did clean removals of all drivers and software. rebooted, Reinstalled everything, rebooted again, plugged in and ran the hydra updater - same response.
We did the jumper on socket 3 between pins 8 and 10, same thing still.
We are running on Windows 8 x64 and Windows Server 2012 x64 across the board (not including phones and windows surface devices which are either RT or 32bit)
Basically we are assuming that the board is RMA and seeing the amount of issues on this forums with the same or similar errors with the updater, we are thinking about just sending it back as RMA and then ordering in some Spiders instead. Although if there is a way to get it up and running that would be great, as express postage to and from GHI and Australia is a bit steep.
If anybody has any ideas as:
[ul]if the board is RMA (ie nothing on the screen - ie is that normal? or the LED status)
how to get it up and running if it’s just a crappy driver issue
if the drivers are signed
if setting up a spider is easier/more stable
are the spiders drivers signed
[/ul]
that would be great

Also, if there is anything (such as the screen displaying something when things are working well) that can be used as a tell tale sign of if things are running or not, that would be great too.

Thankyou all in advance, even if all you do is read part of this, close the thread and wander off and never reply.

James


#2

incidently I’ve used these as references

installation/update
[ul]http://www.ghielectronics.com/docs/125/firmware-update-fez-hydra
http://www.ghielectronics.com/support/.net-micro-framework [/ul]

forum posts
[ul]http://www.ghielectronics.com/community/forum/topic?id=10466
http://www.ghielectronics.com/community/forum/topic?id=8375
http://www.ghielectronics.com/community/forum/topic?id=8813 [/ul]

and I also want to add - does anybody recommend giving up on the hydras in general (if it works we can still use it as an advanced garage door opener etc) and swapping out to spiders?

VS 2012 and VS 2010 are all ultimate versions, using C# (I can get the gadgeteer projects up, however we can’t deploy to them)
Additionally, using MFDeploy, the GHI Hydra is able to be seen.


#3

First, welcome to the forum.

As with everything else, there is a little learning curve, typically one day to one week with gadgeteer, from there you become unstoppable :slight_smile:

You must start with the basics to make sure you have your setup done right. This means, no display no modules, noting.

For example, can you blink the on board LED? http://www.ghielectronics.com/docs/43/first-gadgeteer-project see the code under thinking events


void TheLoop()
{
    while(true)
    {
        // add code
        Thread.Sleep(10);// don't overun the system, always use only the time you need
    }
}
void ProgramStarted()
{
    // Create a timer
    GT.Timer timer = new GT.Timer(500);
    timer.Tick += new GT.Timer.TickEventHandler(timer_Tick);
    timer.Start();
 
    // Let the method return
}
 
bool Is_LED_On = false;
void timer_Tick(GT.Timer timer)
{
    // Do periodic work here
    Mainboard.SetDebugLED(Is_LED_On);
    Is_LED_On = !Is_LED_On;
}

Finally, we are always here to help and ready for questions. Once you do some reading, we can step you though any obstacles.


#4

Hi Gus,
nope - nothing can be deployed (even a blank project with nothing except for a clientSP).

The IDE cant detect it, and the updater cant detect it either.
Thats why we are worried about the device.


#5

we also read through the 7 pages in this thread:
http://www.ghielectronics.com/community/forum/topic?id=9532
however we can’t even get the updater to find the port.


#6

What do you see under device manager?

How are you powering your board? How are all thing connected?


#7

Hi Gus, (I’m on my phone so I apologise for typos and brevity)
as per the first post.
GHI.NET Micro Framework USB Debugging Interface” is availabe.
com1 available
lpt1 available
COM4 GPS Camera unavailable

device is currently powered by around 5.2 volt 510mA usb 2.0 port through a usb client SP (the one that comes with the hydra). This is connected to socket 2 type d via a 10cm cable. No other items are connected.


#8

OK good so the firmware is running on the board. Now, what happens when you use MFDeploy to ping? You should see it under USB and then a ping should return TinyCLR.

Do you have access to a powered hub that you can use?


#9

The “COM4 GPS Camera unavailable” is confusing to me. I think that is what you see when the Hydra bootloader is running?


#10

As a fyi, I’ve had several bad deploys with the Hydra I received this week. The Hydra has gone into this bad state several times(5 so far I think). It’s a crap shoot on the two pins. You contact them, plug in the usb cable, wait 5-7 seconds, remove it, then click Update. If it doesn’t work, unplug usb cable, contact the two pins again, then click update again. If it detects it, that’s when you turn on your external power(I’ve got a 12V) and go ahead with the firmware update. Also important not to have any other modules connected.


#11

hi everybody! 6am and back to work. (still on the phone though so sorry about any typos etc)

Regarding Gus’ ping question:
mfdeploy cannot ping the board. It errors or saying it is unable to communicate withe the hydra as per the documentation ( documentation days that winusb drivers as used by mfdeploy are incompatible with the hydra)
The 5.2 volt 510mAmp is a powered hub.
The low power usb ports seemed to flakey on one machine so I’ve used the powered hubs since.

regarding Mike’s driver query:
whenever a driver is first used by windows vista, 7 ,8, server 2012, it is installed, dumped into drivers and dumped into driverstore. This driver is inactive.
If the device is then detected the driver becomes active and the device becomes in use. If the device isn’t properly detected the driver will remain inactive because windows couldn’t match it.
so in the case of gps com 4 being in active, it means the driver was installed but after that time no matter how many times we plug and unplug and rest the device via pins it never detects it as the gps com4 device so it remains in the inactive state. so in your default manager view, we never see gps com4. If we run Dev manager with hidden devices enabled it shows it as hidden and no device detected.

Regarding nxtwothou response:
admittedly I’ve only tried around 5 times to do the pub reset. If it is as dodgey as you say I might wire up one of the cables with a push button to make that easier.
Do you know if the spider has the same issue by any chance?


#12

So you select USB on MFDeploy and you see Hydra showing up in the list? But then ping button gives no response?

Did you load any firmware on the board or this is how it shipped? And if you did, then did you load the ethernet firmware?

Yes and no answers are sufficient.


#13

short answer. yes mfdeploy was like this from receipt of goods.
After running updater the device was not found. We attempted to use non ethernet firmware except updater couldn’t find the device, so the device is still running whatever it was shipped with.
device was shipped via insured express with tracking via fedex. weather is fine over here. device was received directly from fedex courier. package appears undamaged.

Time line
This is how it was when shipped.
mfdeploy can see the device under usb
vs2010 cannot are the device at all

We then assumed that as some forum posts said that an update was needed we attempted firmware updates, we have tried to install non ethernet firmware. However the update is unable to see the com port at all.

checking device manager the device is never getting a com port

this lead to reinstall.
same response from updater, mfdeploy, vs2010 and devmgr.
attempted manual update around 5 times
same result from updater
loaded custom inf files to replace yhe gps com4 driver work test mode turned on (64 bit win8 so it has driver signing enforcement).
Still no response from the board.

I’ll arrive back in the office in around 1.5 hours where I’ll be rebuilding a spare hp with full powered internal usb with Windows 7 64 bit enterprise and a clean install of vs2010 ultimate then the ghi packages to see if it is an os compatibility issue although that won’t be an acceptable solution as the machines are all win 8 and 2012.


#14

shorter answer
yes. mfdeploy shows the hydra
no. mfdeploy has no response from the hydra
no. the first few tests were before attempting updates
yes. original results were out of the (shiney clear blue) box
n/a. last question not applicable during first round of testing as no body had attempted any updates

second round of testing.
no. we did not attempt to use the ethernet firmwares. we attempted to use non-ethernet firmware however the device was unable to be detected by hydra updater so an update never happened, so the device is still “running” the same firmware.


#15

FYI, I’m using Windows 8 x64 and Visual Studio 2010. My problems were related to deploying code that I guess the hydra didn’t like(used to other devices needing a loop, so treated ProgramStart like one). Since I stopped writing crappy code, I haven’t had to reflash. Development does work fine under Windows 8.


#16

OK, so here’s how I would approach this.

Can you boot into loader mode, using the manual process. See http://www.ghielectronics.com/docs/125/firmware-update-fez-hydra for details. At each reboot, you should see a specific driver in Device Manager. If you boot into bootloader mode, you should see a COM port device; if you’re not getting it to stop in bootloader, you’ll see the netmf device. For the firmware update, you need to be able to see the COM port - the device will become active in DevMgr at that point. You can’t proceed past this point. Just for clarity, here’s the “simplest” routine to get into bootloader mode, extracted from the above link:

Capture screen shots of DevMgr and post them here too. That may also help the diagnosis.

Do you have a “clean” machine you can plug the device into when trying to enter bootloader, so you can see the COM port?


#17

Thanks nx. I doubt it’s my level of crappy coding as was a fresh gadgeteer project compiled fine with 0 warnings or errors and the deploy error was usb gadgeteer not found :slight_smile: I can’t even get to the stage where bad software code matters! I would be very happy if I was able to give one of these things to an intern and let them crash it due to poor coding.
However thank you for letting me know that you run Windows 8 x64 as that atleast means that it is doable. do you know of you have device driver signing enforcement turned on or off?
Thanks again for your response.


#18

Hi Brett, I’ve tried that once however it wasn’t on a clean machine.
I’ll grab a fresh laptop out of an unopened box and start from scratch with a manual update and post the results as you’ve requested. I’m still atleast an hour from the office however.


#19

Please do not update or load anything till you have verified that the device shows in MFDeploy and you can ping the device and get a response.

Make sure you download the required software in the exact steps and exact software showing here http://www.ghielectronics.com/support/.net-micro-framework


#20

Personally, on a fresh laptop I would not install the software yet, and purely boot into bootloader mode and make sure the GPS COM device shows up in DevMgr. That way you know you’re getting into BL mode and then you can get back onto the other machine (or proceed with the software install on the new PC and then get firmware updating)