Main Site Documentation

New gadgeteer issues


#1

Well - came yesterday and since I was working at home… you know - while my server projects were compiling…

First issue is that I wasn’t able to update firmware - although from looking at info from MFDeploy, and with screen on, at the startup debug display in serial mode, it looks like the firmware is the latest already (4.1.7.0). When I follow the instructions on the FEZ Spider Updater - on pushing the “update” button, I get a dialog with “Cannot connect to the device! Follow steps 1 to 2”.
Of note, after I set the switches to (0111) and press reset, I get the USB disconnect chime, but no connect chime from Windows (windows 7 ultimate, 32 bit). This may have been self-caused (this last part) because I played around with MFDeploy after I couldn’t update firmware a number of times and hit ‘erase’ on it - although basic operation is still fine). Additional symptom - setting the USB/Serial switch to serial in update mode, the display shows as expected, but in USB position, it shows boot info, then gets blurry, then overwrites to grey, then fades. Looks like boot loader is failing in USB / firmware update position?

2nd - Tried to do the spider example using camera and display. The camera doesn’t appear to work. Followed the instructions pretty precisely - my code and spider looks the same as in the example. However, on checking camera.CameraReady in ProgramStartup, it always returns false. When TakePicture is called, output reports “Camera ERROR : Unable to take picture. Camera is not ready. Is the Camera connected?”

3rd - I tried to write some text to the display, and can’t seem to make that work either - I’m using the display.SimpleGraphics.DisplayText - like:


           display.SimpleGraphics.DisplayText("Starting", Resources.GetFont(Resources.FontResources.small), GT.Color.White, 24, 24);
            display.SimpleGraphics.DisplayEllipse(GT.Color.White, 160, 120, 140, 100);

I get nothing on the display - is there some Flush call or something to be made?
For the display - I’m pretty sure it’s fine - it displays text during boot, and if I set the USB/Serial switch to serial, it sticks around long enough to read.
wait! I just pressed reset after the debug run, and my display above shows up briefly… hmmm…

4th - when I connect the touchpanel cable (and indicate that in Program.gadgeteer diagram), I get a NullReferenceException after ProgramStarted completes. If I use the 3 cable form, I do not.
Is there some other initialization one needs with the touch panel input?

And finally - I’m not having any problems making switches and led’s sing and dance - so basic function and programmability appears to be fine - I haven’t tried the other modules yet so I’m not sure where they stand.

Any suggestions on any of the above issues?

–Hugh


#2

We like to handle issues in separate threads please. Easier for us to track and for others to learn from your questions. Gadgeter is still new and any posts here will be very valuable to others.

I will make my answers short, more details come later, hopefully in separate threads.

  1. You do not need to update firmware, at least for now. We shipped them all with latest. We will have more details in few days.

  2. Possible problem. Can you try the USB Host module to at least make sure the mainboard is fine?

  3. We are shooting for more examples/tutorial to make this easy. I believe that the “display.simplegaphics” is simply the internal Bitmap object of the display. So yes you need to flush the graphics look here http://tinyclr.com/support/ for “display crash course” to learn on how to use “Bitmap” object

  4. Please make new post and include your code so we can try to repro on our end.

I hope you are enjoying your new kit and we look forward ot seeing some exciting projects.


#3

Gus:

The display.SimpleGraphics is not the Bitmap for the display. The Bitmap for the display is a private member.

display.SimpleGraphics has a property call AutoDraw. When this is set to true, then the flush is automatically done when a graphics command is issued. If it is set to false, the a Redraw() method must be called to flush the bitmap. The default for AutoDraw is true;

??? ???