NETFM cant update Cerberus Firmware?

Hello Guys,
im very new to .NET we had to buy a Cerberus Starter Kit for school, because we wanted to build a little roboter with the Microcontroller.
I wanted to set it up before we start it in school and i ran over a problem. I downloaded and installed the .NET Microframework 4.3 RTM (for Visual Studio 2012) and then the GHI NETFM and .NET Gadgeteer package. I started up NETFM and at the setup screen i had the option to update the Firmware for all the other Gadgeteers but the Cerberus(the options were: EMX FEZ Cobra, FEZ Spider, FEZ Hydra and G120). Do i need to install another software for the Cerberus ?
Please help me.

PS: im sorry for spelling mistakes etc. im from Germany and i cant speak that good english


The update process for Cerberus family boards is a little different than our other boards. You can learn about the process by reading this wiki page

Hi i tried it out and i stuck at loading TinyCLR i opened MFDeploy and the Cerberus got detected i browsed the firmware and configuration file but after clicking deploy i got an error “Error: No response from device” The Cerberus is detected by Windows and the Programm. Then i just tried to deploy the firmware it loads the firmware.hex but when it tries to execute the application it gets the same error.


@ -Encore-

Welcome to the community.

Did you follow the portion of the Update process where you need to erase the entire board and load Tinybooter to the board first?

Your screenshot shows that you are missing Config.hex. Make sure you have it too.

@ Aron - yes i followed the instructions excatly as it was described.
I have an idea i use the .NET Microframework 4.3 RTM (for Visual Studio 2012) is that the problem, because in the instructions the Microsoft .NET Micro Framework 4.2 QFE2 SDK is required.

Yes. MF 4.3 is not support by GHI yet.

@ Architect - As is said in the post before i tried it both ways with and without. Both ways wouldnt work.

@ Mike - Ok thanks, but will visual studio 2012 work with 4.2 ?

I don’t think it does, but I am not sure.

@ Mike - ok thank you either way :wink: