Main Site Documentation

Need help setting up Yagarto for an RLP project


#1

I followed the instructions on the RLP wiki page, and went to the http://www.yagarto.de/ link, but that link redirects to http://www.yagarto.org/, which doesn’t have the Yagarto install files. Then I tried the Yagarto project on SourceForge, and downloaded this file:

yagarto-bu-2.23.1_gcc-4.7.2-c-c++_nl-1.20.0_gdb-7.5.1_eabi_20121222.exe

Running this executable installs Yagarto, and sets up a path environment variable. Everything is good so far.

Next, I tried running “make --version” from a command prompt and got this error:

‘make’ is not recognized as an internal or external command, operable program or batch file.

I did a “dir” on the Yagarto directory and got the list shown in the attached image.

Should there be a “make.exe” file in that directory? If not, where is the make file located?

Thanks for you help.


#2

Search for yagarto-tools-20100703-setup.exe
Make sure you install it in a folder with no spaces eg. C:\yagarto
Filesize is 1.229.209 bytes


#3

Thanks @ Hyperlisk, that solved the problem.


#4

This is a more up-to-date (2012 vs. 2010) link for the Yagarto Tools:
https://code.google.com/p/csud/downloads/detail?name=yagarto-tools-20121018-setup.exe&can=2&q=

If you have another compiler installed that contains a make utility and its path appears before the Yagarto then the Yagarto make will not be invoked!

What you have to do is simply include the path to the Yagato make when in you invoke it,
such as:

C:_yagarto\tools\bin\make (in my case)

I installed Yagarto Tool Chain in _yagarto then the tools in _yagarto\tools

Good luck!