Main Site Documentation

Need for the download of the load-mode driver for FEZ Hydra


#1

Hi friends,

I am now trying to update the firmware of FEZ Hydra on another computer.
After reading many docs, I found that each main board has 2 different driver; one for normal use, and another for loader mode(cannot remember from where I saw this info).

Now, after plugging/unplugging my Hydra thousands times on the 2nd PC, it is now pops up dialog telling me to Update Driver Software and the previous GHI General XXX driver has done in the Device Manager.
So I guess this time it recognizes the load mode and now is trying to install the relative driver.

So could someone point me out the download link of this load mode driver please?

I am waiting for your reply.

Thanks a lot


#2

All drivers are included in the SDK, and should be installed on the computer already.


#3

@ franva - If you have plugged/unplugged your device several thousand times, most likely you have damaged the USB socket or plug. :open_mouth:


#4

Thx mate, I found them and tried to install them, still doesn’t work.

I guess I will have to wait for the DP module.

Thx again


#5

hahahaha


#6

Personally, getting one weird device connection like this suggests to uninstall the GHI drivers (use the remove files option) and reinstall from scratch. Methodically disconnect all cables from your device, check the pins look correct, check the socket type is correct and plug your SP module back in. Then connect the USB cable carefully to SP, and plug the device into the PC. Make sure you hear the device connected noise from the pc, and then the driver should start correctly. If that fails, repeat this on all available USB ports, as often some ports may have dodgy power connections.

Can you tell us about your history with this hydra and your pc’s? Have you used them together in the past, or is this a first time setup for you? Have you ever had the GHI SDK installed before?


#7

Hi Brett,

Thank you for your detailed explanation.
This is the 1st time I setup this kit and I didn’t use it since I got it at all.

After reading many posts and docs on this website, I found that Uploading firmware requires high power supply on several webpages in this website.
So I decide to wait for the delivery of my DP.

I will keep you posted about my progress once I got it.

Thank you mate


#8

I can’t be sure, I don’t think I have a spare DP module though :frowning: I’ve emailed you direct and still happy to send you a Hydra to test and get you started and if I do have a spare DP I’ll happily send it (or perhaps I can wire up something - let me think on that :slight_smile: )


#9

Hi Brett,

Thank you very much for your reply and warm-heart help.

The DP module is only need for updating firmware (because according to what it is said on this website, when updating firmware a strong power supply is needed.)

But since you will send me the updated hardware, then I do not need DP module to do my test.
So please send me your update-to-date Hydra (Version 4.2, I guess) and I highly appreciate your help!!!Really!


#10

An update here for anyone playing along at home (Winston and I probably :slight_smile: )

I got Winston’s Hydra in the mail today. I used https://www.ghielectronics.com/docs/125/loader-tinybooter-update-fez-hydra and “option 2” to get the tinybooter updated, and then used FezConfig to deploy the CLR. All worked first time.

Points back to a PC thing. I’m just using a USB3 port on my regular laptop, plugged into a DP module (without external power). I’ll email you back and figure out what, if anything, we should do next!


#11

A big thank-you Brett :slight_smile:

I am really happy to know the result, the only difference is I used a USB2 interface and it’s USB3 in your place.

I’m not sure whether this affects the outcome and I am sure we use the same driver for the hardware(which comes from the latest installation package).

Looking forward to any what-should-do-next :slight_smile:

Cheers mate :slight_smile:


#12

Honestly, USB2 has historically been more reliable than USB3. I don’t know what to suggest really, it just seems um well, a mystery.

Do you have a desktop PC or old laptop ? Any way to test on another PC?


#13

I have a laptop pc with Windows 8.1(Lenovo E530, bought in May, 2012) and also tested on Samsung XE700 a tablet PC with Windows 7.

NVM, as long as it works now, I am happy :slight_smile:

Also, hopefully I can find some info about how to install and operate relay to control switch on/off appliances(light bulbs first)

Cheers,

Winston


#14

we really need you to be able to update this yourself, because you really will hit situations where you will need to - like when GHI do release the next SDK version that supports 4.3 !

I think it’s driver removal time. Will take the debug over to email first up