MSdeploy Cerbuino Bee Firmware

Hi,
Just got my Cerbuino Bee and wanted to update it to the lastest firmware,
I followed the wiki page GHI Electronics – Where Hardware Meets Software.
I updated the tintbooter ok with STDDFU tester ok.
when I change over to MSdeploy & select USB the Bee does not show up.
I tried this with the LFR pad open & closed and reset the card, replugged the usb port & tried an exterial power supply
any suggestions which way to hold my tongue to make it work ?

Colin

@ Colin_T - Welcome Colin,

Are you using MsDeploy from the 4.2 folder

LDR Pads open when doing the MSdeploy

Yes Justin,
I removed all the 4.1 files and the old ghi files. at least I think I got them all
msdeploy V 4.2.0.0

Hi Colin_T,

Welcome to the community.

Can you describe all of the steps that you took to flash the board? It sounds as if the TinyBooter flashing did not take.

Hi Aron,
the steps are
I close the LDR ling
I plug in the USB
start STDFU tested
The device list shows STM in DFU mode
select the protocol Tab
select erase
click go
Success is shown at the buttom of the screen with a complete blue status bar
select downwload
click load DFU file
select C:\Program Files\GHI Electronics\GHI OSHW NETMF v4.2 SDK\FEZ Cerberus\Firmware\TinyBooter_4_2_1_1.dfu
date 22/6/12 40kb

Success is shown at the buttom of the screen with a complete blue status bar see picture
Close DFU tester
start MSdeploy
reset Bee
select USB
and the respoce is blank for the Device

I have reinstalled the USB drivers with no change
and i tested MSdeploy with a Fez rhino and it detected
any suggestions?

Colin

I also remove the LDR link before I try msdeploy

@ Colin_T

The steps that you listed omits one step that you may not have done. Repeat the steps as you did but before clicking Go when you select erase, click on Create from Map button to bring up a blank flash map. I do not think that the chip erases unless you do this step.

Well now I now what the blue question mark does

back to the saga
I erased as Aron described but still no joy with MSdeploy
so off to work I go and try it on an other PC and MS deploy is good and now I have an updated Bee
So tonight it looks like some re installing is required

Thanks for the help

Hi Aron,
I am not certain if your erase method did the trick but now both mu PC reconigise the Bee
So now its off to learn whats it good for

Colin

Did you do something other than what the wiki described?