Main Site Documentation

Module documentation is included in the designer


#1

When you have the designer open, select the module you added (click on it) and then hit F1 … enjoy! :slight_smile:


#2

I’ve just tried it. Works great! Thanks. ;D


#3

It appears that F1 only displays the information in the GHI class.

In the case of the T35 display, which inherits a MS Display class, all the goodies do not appear in the F1 info. The F1 display does not show the inheritance hierarchy, which normally appears in the documentation.

But… it is a start :smiley:


#4

Correct and we have already requested this to be looked into by Microsoft.

Fro now, check this file C:\Program Files (x86)\Microsoft .NET Gadgeteer\Core\Assemblies.NET Micro Framework 4.1\Gadgeteer.xml

Is there a tool that shows these documentation xml files better?


#5

@ Gus - Yes, there are several. The best one, IMHO, is SandCastle, and comes with a UI tool that makes it pretty easy to crank out nice looking documentation as a website, CHM file, PDF, etc, etc… basically some really fancy XSLT.

check out

http://sandcastle.codeplex.com/ (the guts)
http://shfb.codeplex.com/ (the UI)


#6

Funny, I think the guys at GHI do use sandcastle! I just never tried it myself.


#7

Your online documentation looks like one of the default sandcastle templates. Microsoft uses it for MSDN, albeit with heavy use of custom transforms and a whole team of technical writers…


#8

Hi

As a learning opportunity I made an attempt to use Sandcastle to produce a help file from C:\Program Files (x86)\Microsoft .NET Gadgeteer\Core\Assemblies.NET Micro Framework 4.1\Gadgeteer.xml as suggested.

The process failed when SandCastle came across a reference to a source code example that looks like:

            <example>
            In the following example, twelve lines of text are placed on the display. Because
            the <see cref="P:Gadgeteer.Modules.Module.DisplayModule.SimpleGraphicsInterface.AutoRedraw"/> property is set to <b>false</b>, the lines do not render
            individually. Instead, they are rendered in one batch when the <see cref="M:Gadgeteer.Modules.Module.DisplayModule.SimpleGraphicsInterface.Redraw"/>
            method is called.
            <code source="SimpleDisplay\Program.cs" region="AutoRedrawDemo" title="Improving performance with AutoRedraw" lang="cs"/>
            </example>

The Gadgeteer SDK didn’t seem to install these on my computer. Just wondering … do these exist and if so are they useful as examples in the FEZ Spider context?


#9

@ LenF - the GHI gadgetter installer only gives you the dlls. Sandcastle needs the source files to extract the XML comments. The source is at http://gadgeteer.codeplex.com.

Creating a help files from GHI and MS source code for all of the current code would be a good project for someone looking to gain kudos in this forum. Because this is a beta project, however, the code (and hence comments) will be changing quite a bit in the near term.

Maybe we can get GHI and MS to add this as part of their SDK updates.


#10

I got a confirmation from the gadgeteer team about them generating the documentation for all of us :clap:


#11

So has this happened? Is the documentation available ?


#12

Hi,

The GadgeteerCore reference docs are posted in a .zip archive at http://gadgeteer.codeplex.com/releases. We’re working on posting them to the main Gadgeteer Web site at http://netmf.com/gadgeteer so that you can browse them online, too. I’m working on that this afternoon.

Thanks,
Kerry


#13

Kerry - Thanks! Any chance you can publish VS2010 compatible help files or a CHM? It would be nice to have this indexed and searchable.

Welcome to the forum! A lot of Gadgeteer “early adopters” can be found here!


#14

Thanks, ransomhall!

The online-browsable docs are up at http://www.netmf.com/gadgeteer/docs/gadgeteercore/index.html now. We can build a CHM too, I’ll post that shortly.


#15

Hello Kerry! :slight_smile:

Welcome to our forum.

To whom that does not know Kerry Hammil. She is one of the most enthusiastic members of .NET Gadgeteer team. Check this webcast to see what I mean :wink:
http://www.dotnetrocks.com/default.aspx?showNum=694


#16

Thanks, Joe! ;D I’ve been lurking here for a while and have finally come out of the shadows.

The GadgeteerCore CHM is posted at http://gadgeteer.codeplex.com/releases/view/78441#DownloadId=311851


#17

Great. Thanks Kerry. We will add this to our “master download” page as well http://tinyclr.com/support/

BTW, is this your cat? I always get into an argument with my wife as for kittens vs puppies. Kittens is what I say :wink:


#18

Hi there,
thank you for the update. but after downloading the CHM file and opening none of the links work they all display page not found.

thanks.


#19

@ JayJay - You have to unblock the file after you download it. Also, you can’t run CHMs from a network location. They have to be on your local machine.

@ Kerry - thx for the CHM.


#20

@ JayJay

There is a trailing dot in Kerry’s link. Remove it.

Edit: Nevermind. I thought you had trouble downloading the file.