Main Site Documentation

Missing something using FezTerm


#1

Hi,

I was wondering if someone can point me in the right direction please?

I am trying out the FezTerm sample kindly provided and I can get it to work fine when using the included FezTerm app but when I try to connect to the board with TeraTerm/HT or Putty nothing seems to happen. Literately nothing. I am on the same COM port that FezTerm used, settings shouldn’t matter but I have them the same as in FezTerm, just nothing happens, no response. I have tried this on 2 machines and still same problem so I know it is something I have missed…

Any ideas please?

Thanks in advance,

Andy


#2

Try the TeraTerm version provided on the downloads page.


#3

Hi Joe,

Thanks for coming back to me. I am using the version from the website. I even downloaded it again just in case. Still nothing works… I know this is going to be something silly, but I just can’t see it…

//A


#4

Mkae sure you select the ‘1K’ option when downloading…


#5

Do you mean that you are not getting any responses from FEZ? What happens if you hit V or v


#6

Thanks for coming back to me.

Gus: When I press ‘v’ I get nothing, no key press seems to be accepted by the sessions. The only ones that work are the ones in the FezTerm app. There it all works perfectly, but as soon as I close it to close the port on the PC side no other apps work. The weird part is if I then open up FezTerm again it carries on working. I haven’t typed exit or anything just left it running. This is on 2 separate machines as well…

Jeff_Birt: I’m not downloading anything to the Domino so shouldn’t need the 1K option??

Any ideas what I’m doing wrong?

Thanks,

//A


#7

Hold on… Fez term works with a virtual comm port…Tera term requires the device drivers and is then on a completely different port… Unless you install the drivers tera term wont see the domino

When I talk to tera term I have to invoke the LDR button.

Am I missing something… or does the CDC driver on the domino get recognised by the PC as a com port?

Cheers Ian


#8

Hi,

I agree, I think it may have something to do with the drivers but I am not sure what…

As it is using the USBClientController.StandardDevices.StartCDC_WithDebugging in the Domino code then as I understood it if you installed the correct drivers:

http://ghielectronics.com/downloads/NETMF/Library%20Documentation/GHI_NETMF_Interface_with_CDC.zip

then it should see it as a virtual COM port? When I connect successfully via FezTerm then in my case it is on COM4. When I shut down FezTerm (to close any links to open ports etc) and open TT and connect via COM4 (which is still the only one on the list…) it doesn’t respond to any commands at all. I get a flashing box and it will not accept any input.

I think I need to short out the MODE pin and change the Domino code to just ‘StartCDC’ and see if that makes a difference (with the correct drivers!)

Thanks again for everyone’s input.

Kind regards,

Andy


#9

Hi,

Still no luck.

Switched to the straight’ USBClientController.StandardDevices.StartCDC()’ option . Switched the windows drivers and it now comes up as COM5 . The only PC interface that works is the FezTerm. All other software refuses to respond to any input on my side. I can close down FezTerm and restart it again and no problems, works like a dream. The rest of it on the other hand…

This is driving me nuts, does anyone have any ideas what I could be doing wrong?

Thanks in advance,

Andy


#10

Are you trying to update firmware to use CDC class?! Maybe this is where the confusion is


#11

Hi Gus,

Thanks for your reply.

All I am trying to do is to get the example provided to work with any host software as opposed to at the moment it only working with FezTerm.

I am not looking to update anything, debug anything or anything else. Just to be able to open either HyperTerminal, putty, Tera Term or whatever and press the ‘?’ and get back the same info I would if I went into FezTerm…

I hope this makes sense. If not please say.

Thanks again.

Andy


#12

I think you’re going to have to use a different USB configuration… at the moment the PC isn’t seeing a serial communication… I am hopeless with all the different USB setup’s… but untill windows see’s a comm port, teraterm, hyperterm etc… can’t see the domino…

Cheers Ian


#13

Hi Ian,

I can promise you it is seeing a COM Port: (see attached image)

Every application can see the right COM port, but the only one that can talk to the Domino is FezTerm…

//A


#14

Are you debugging over serial then and using USB as a CDC device?
Good, now where is the simple code you are using for testing? Maybe a program that sends “hello” once a second?

You keep bringing up fezterm but I am not not familiar much with and it is not official software. Do not give up…we just need to understand your setup so we can help you


#15

Thanks for your help so far and sorry for any confusion on my part. I have spent several years on your side of the fence in support so I should really know better! :-[

To answer your questions:

Yes I am debugging over the serial port, the Mode header has been shorted at startup.

FezTerm refers to the working example provided by William when you kindly brought out the debug and CDC over USB. It can be found here: http://www.tinyclr.com/forum/7/1363/

It was supposed to be working software so I hadn’t gone down the route of simple code just yet. The problem was I was trying to get my head round how it was working to then create the simple code! I always start with working code first, if I can, to get my head round how something works then build up from there.

My original problem was all the samples I could find to get the USB_CDC working only covered the .Write method and it was the .Read that I was struggling with. Hence the example was a good place to start to understand the .Read method but then I hit this problem.

Thanks again,

Andy


#16

What serial port settings are you using ? 9800,n,8,1 is what FezTerm uses.

The other thing you probably need to do is turn local echo on so that you can see what you send, since FezTerm displays the text (Fez doesn’t echo it) - but if you send the right text commands you should see a response anyway (which is why I think Baud rate is your main issue)


#17

FezTerm is not a standard vt terminal as such. Sorry if I did not make that clear in the docs. It has its own protocol as was designed more as an end-to-end deal with the host on the fez and the Win client on the PC side. v1 just used newline \n for line end, so should should see something with teraterm as long as you don’t start the windows FezTerm which would grab the port and you can’t share comm ports afaik. Did not really text with teraterm however.

v2 will go lower and abstract an IPort (serial, etc) into UDP like clients with local/remote port numbers. This allowed me to more easily integrate file transfers and things like Events out-of-band from the main console session. So will not be able to use other serial term apps.


#18

Hi Brett,

Thanks for your help. Those were what I was using. I noticed that that was what FezTerm was using so had kept to those defaults.

I didn’t think that the port settings would matter and I had this confirmed IIRC by a post from Gus but I can’t find it now for love nor money! Can anyone confirm this please?

I will post a selection of images from FezTerm, TT and Putty to show you what I am getting. THe only time I get any kind of response is still in FezTerm…

Thanks again for your help.

Andy


#19

Tera Term Screen shot


#20

Putty Screen shot