Main Site Documentation

MFDeploy Tool Issues


#1

Trying to deploy using the MFDeploy Tool. Created an Applicaiton Deployment, created keys, signed the key and then tried to deploy the hex file. I get a signature failed everytime. Any idea on what I’m doing wrong? We really need the ability to deploy hex files to EMX.

Dale


#2

Did you update TinyBooter and firmware to the latest and greatest? And then you tried this with a small blinking LED before trying final application?


#3

We have the latest firmware and tinybooter. We will get back to you on the sample program test.

Dale


#4

Do you have the latest firmware?

Did you install a deployment key in MFDeploy (using Update device keys)? Please first try it without this option.

If you start fresh and try the following, it should work fine:
Erase your EMX from bootloader and install tinybooter and firmware (latest).
Make a new console application and deploy to device.
Read using MFDeploy.
You should be able to deploy it back…


#5

Still fails on Signature.

Dale


#6

Steps we did:

  1. Boot into tinybooter and Erase Memeory
  2. Reload booter
  3. Deploy CLR, Config, CLR2
  4. Build/compile and deploy new MF app
  5. MFDeploy -> Application Deployment -> Create Application Deployment
  6. Save hex file, click create keys
  7. After reboot -> clear emx memory
  8. Deploy hex file from MFDeploy.

Dale


#7

step 1 should be, enter GHI loader (hold 3 buttons) and erase all using E command.


#8

Yes that is what I did, meant GHI Loader not tiny booter. Please help me out here.

Dale


#9

what is the firmware version number you are using?


#10

I just tried it again here. It is working fine…
Look at your LCD in TinyBooter mode. What is the version number?
Look at your LCD in TinyCLR mode. What is the version number?
I don’t think this affects it but do you have your hex and sig files in the same folder?
Are you sure you are not updating device keys?


#11

TinyBooter Mode: Version 4.1.3.0
TinyCLR Mode: Version 4.1.3.0

Yes I am absolutley sure I am not updating the device keys, and yes I have the hex and sig files in the same directory.

Dale


#12

We are trying something different. Will get back to you on the outcome, but we were able to get it to deploy so we think there may be a bug somewhere with MS stuff.

Dale


#13

What was the issue with the MFDeploy?


#14

Ok here is what I found out. If you create the application and immediately deploy it again, then it works fine and deploys. However, if you create the application and then load a different application on it or erase the current application and then deploy the original it will fail the signature check. GHI can you confirm?

Dale


#15

Still works fine here.
It seems you are trying to load different applications and not simple tests. In this case it is hard for us to help you.
Try something very simple first like a console application. Read it, erase deployment, deploy again. It should work.
Maybe you are having a problem with a specific application? We need exact steps with exact programs that are failing.


#16

It is really simple. One program with a blinking led. Deploy through Visual Studio. Read back from MFDeploy. Erase. Then deploy the hex file from MFDeploy. Nothing strange there. We will call you.

Dale


#17

I don’t understand how your even getting hex file. Is this cobra?


#18

He is using “application deployment”. Search MFDeploy docs


#19

@ Gus. I seem to going in a circle here on this issue. On my systems (panda and domino), I can’t use MFDeploy for application deployment. On Panda, for example, when I click “Create Application Deployment”. I get error “Device has old or unsupported configuration”. I had thought you said before because USBizi does not support this from MFDeploy (maybe I am mis-understanding).

So can I get a yes or no. Should USBizi be able to support this or just cobra? Do I need to keep looking for why I am getting this error.


#20

the answer is there http://www.tinyclr.com/forum/1/2147/