MFdeploy hanging on checking signature on Cerbuino Bee

Just installed the August 24th, RC2 for NETMF 4.2 QFE2.
Following the wiki for the Cereb firmware update
Trying to update firmware but mfdeploy has been sitting at checking signature for >10 minutes now.
any suggestions?

i am using the non ethernet firmware

actually it just gave me signature failed message also

Did you update the tiny boot loader also?

yes to TinyBooter_4_2_3_0.dfu

I changed usb ports and it worked this time.

Let me know if you are able to deploy a Gadgeteer project (more than once) to your bee.

yep done it a few times now

@ MikeCormier - Hiya Mike, i’m having the same issue with trying to update my Bee, gets stuck on the signature.
Did you find the problem or was it just give it a slap and it’s happy again?

i just moved usb ports to a powered on not on on my laptop.
I don’t know if that did anything or if it just started working.

I’ve tried all USB ports (3) on the same laptop with no joy. Will move to a workstation next, just to be sure.

hmmm, about to try on another machine as nothing else seems to work…fingers, toes and everything else crossed…

I used an external powered hub and it worked.
i tried it a few times and it worked every time from the hub

GHI released an update to the Cerb family firmware yesterday. Guess there were issues… post #1 has been updated.

@ ransomhall - nope they both have the same issue for me…

Have you tried different USB ports and/or USB cables or maybe try a different cable from DP/SP module. Also try to add external power to the board/module. We are testing more here but have not yet encountered these issues.

@ Aron - yup all the usual suspects fail - needed a fresh dev install and all happy…

It’s alive…

I am having this problem as well. Justin, what was your solution? I have tried reloading the TinyBooter multiple times and then the TinyCLR with the “Checking Signature” Box not completing. I have tried multiple USB ports as said above as well.


@ jkane121 - I’m afraid it was a re format and clean install of windows and VS in my case…

@ jkane121- try using an external powered usb hub. That worked for me.