Main Site Documentation

Mfdelpoy can't detect Fez panda II


#1

Hi guys i’m a newbie and having a problem detecting my fez panda II with Mfdeploy. Do you guys have any idea why? Windows actually detects it but it says installion of device failed and it doesn’t even make the sound “tada” when you usually connect something on usb

There’s already a program in the fez panda II but i’m not the one who did it .

Actually found this : https://www.ghielectronics.com/community/forum/topic?id=6887

"Simple tests please.

Open Device Manager.

With nothing connected, in device manager you should not see anything about a Debuggable .Net device. You should also NOT see any extra COM ports other than what your usual machine gives.

Plug in the Panda. It should recognise your device and show it as a Debuggable .Net device in device manager.

Unplug it again. Device manager should make it disappear.

Hold down the LDR button and then plug it in. You should see the GHI Boot Loader interface pop up as a COM port.

Please confirm all that works - that confirms that the device should be recognisable and updateable."

AND THIS DOESN’T WORK FOR ME what should i do. Ithink the device isn’t recognisable.


#2

The first thing I would try do is re-install the firmware. https://www.ghielectronics.com/docs/53/firmware-update-usbizi


#3

@ Mike Hi thx for the response but the i can’t update the device, I’ve done what they’ve said like the first three things to do (pushing the buttons etc…) but fez panda just cant be connected and i have no idea why…
I’ve attached the picture of what the updater says and what windows says…


#4

@ tomoya7 - have you followed the instructions in https://www.ghielectronics.com/docs/165/netmf-and-gadgeteer-troubleshooting ?

I would also consider uninstalling all the MF software and then reinstalling.


#5

@ Mike Yes i did but my compute doesn’t detect fez panda II


#6

Ah ok, I see you’ve posted here too.

Fundamentally, until you get the device showing up correctly in Device Manager, there’s no value in going to any other tool to check if it’s accessible.

Step 1: Tell us about the history of being able to use this Panda2 and now no longer being able to. Has it and your laptop been sitting in a cupboard for months, or has this just started to happen?

Step 2: Check what LED status you have. If the LED doesn’t come on it is possible the USB cable is broken.

Step 3: Tell us about the devices that you can see when you do and don’t use the LDR button; does it show up at all when in LDR mode, or when not?


#7

Step 1: Tell us about the history of being able to use this Panda2 and now no longer being able to. Has it and your laptop been sitting in a cupboard for months, or has this just started to happen?

The fez panda ii isn’t mine it’s my school’s fez panda II. So i don’t really know the history of this device but it was recently programmed by my teacher like 2 months ago and the program is still working on it with fez touch. I use my laptop everyday so i don’t think it’s the problem usb ports are working fine cause i tested it with my phone.

Step 2: Check what LED status you have. If the LED doesn’t come on it is possible the USB cable is broken.

When i connect fez panda to the computer the led does turn on.

Step 3: Tell us about the devices that you can see when you do and don’t use the LDR button; does it show up at all when in LDR mode, or when not?

When i connect it to the computer without touching anything, nothing happens on the computer, fez panda and fez touch just turns on. When i enter on ldr mode by holding the ldr button and connect it to the computer 1/5 of the time ah notification appears that windows can’t recognize the device and disabled it like the image attached.