MetaDataProcessor exited with code -1073741515

Environment: Windows 10, MSVS 2013, .NETMF 4.3

Working on my first Gadgeteer project with FEZ Spider Starter Kit but using the T43 display.

I was making progress originally with various modules attached but the TE35 that came with the Starter Kit showed only a blank screen.
With the T43 attached I at least got the startup messages.

At some point, not sure exactly when, I started receiving the above message. I also noticed that I had 22 warnings from the Device.targets file referring to invalid child elements. Here is an example:

Warning 18 The element ‘Target’ in namespace ‘’ has invalid child element ‘ResolveRuntimeDependencies’ in namespace ‘’. List of possible elements expected: 'Task, AL, AspNetCompiler, AssignCulture, AssignProjectConfiguration, AssignTargetPath, AxImp, CallTarget, CombinePath, ConvertToAbsolutePath, Copy, CreateCSharpManifestResourceName, CreateItem, CreateProperty, CreateVisualBasicManifestResourceName, Csc, Delete, Error, Exec, FindAppConfigFile, FindInList, FindUnderPath, FormatUrl, FormatVersion, GenerateApplicationManifest, GenerateBootstrapper, GenerateDeploymentManifest, GenerateResource, GenerateTrustInfo, GetAssemblyIdentity, GetFrameworkPath, GetFrameworkSdkPath, GetReferenceAssemblyPaths, LC, MakeDir, Message, Move, MSBuild, ReadLinesFromFile, RegisterAssembly, RemoveDir, RemoveDuplicates, RequiresFramework35SP1Assembly, ResolveAssemblyReference, ResolveComReference, ResolveKeySource, ResolveManifestFiles, ResolveNativeReference, ResolveNonMSBuildProjectOutput, SGen, SignFile, TlbImp, Touch, UnregisterAssembly, UpdateManifest, Vbc, VCBuild, Warning, WriteCodeFragment, WriteLinesToFile, XslTransformation, CodeAnalysis, CL, Link, BSCMake, CPPClean, Get…
C:\Program Files (x86)\MSBuild\Microsoft.NET Micro Framework\v4.3\Device.targets 499 6 Miscellaneous Files

I tried a clean project with no modules connected to the Spider but to no avail.
The FEZ config says everything is up to date.

Any help would be appreciated.


Hey Lou, welcome !

Not a common issue and it looks to me like something in your installation hasn’t worked properly (although I have little evidence to directly support that).

I would uninstall all the netmf related pieces in the reverse order you installed them from, based on .NET Micro Framework – GHI Electronics and then go back and reinstall them from fresh downloads.

You could also attempt to create a new netmf console application, which will target the emulator by default, and see if that works - it will tell you if the fundamental building blocks of netmf are working and it might help identify which layer in the SDK chain is causing you an issue, but I think the best bet first up is “fresh everything”. You might even have to go to fresh install of VS, if a fresh SDK chain doesn’t help

I ran into the following with NETMF on a clean Win10 / VS2013, maybe it is related to what you are seeing

Took Brett’s advice, uninstalling and reinstalling and I am now looking at a multicolor led flashing (to a GT.Timer) and a string on the T43 indicating the press and release of the button.

So I have made progress but obviously am not able to state why but then again I am living in a Windows world and this is not the first time that an uninstall and reinstall has made my life better (and I am sure it won’t be the last).


1 Like