Medusa S12 & Medusa mini not recognized >:)


After buying from kickstarter one medusa S12 and one medusa mini, I have finally find the time to play a bit with them (never too late) .

But Neither the S12 nor the mini are recogbized when i plugg them.

I’ve tried on on windows 8.1, windows 7 pro and Mac OS, on USB 2, USB 3, with and without the battery module (

The ligth (of both model) is blinking but no one is recognized by the OS …

Any recommendations ?


It should show up as a new COM Port in the DeviceManager. It is an Arduino board. Do you have any other Arduino boards?


Thanks for your reply. Yes I know it’s supposed to be viewed as a new COM port in the Device manager but it is not the case ;(

Yes I have many arduino board (all functionning perfectly).

Very strange …

tried different USB cables ?

It’s extremely unlikely that you’d get two failures on two different modules like this, with the same failure state. Do you get the device connected sounds when you connect them ? Does device manager do an automatic refresh when you connect them ?

I just recently re-installed Windows 8.1 on my PC. When I read this post I thought I’ll try it out quickly myself. Plugged in my Medusa board with the USB Client SP Module. Windows detected it and installed the drivers etc and afterwards it appeared as COM7. I cannot think why it does not work on your PC.

You actually do not need to plug anything in the usb module to see a virtual COM port.

Make sure you have the right module though, the one with the ftdi chip.

Also, the battery module can only be used for power but not COM port. However it can be used for programming on the netmf devices, not medusa. Check the socket type.

Shame on me :-[ :-[

I was using the wrong module and indeed with the good one : USB-Serial Module

it works …

thanks again.

New issue :

The Fez Medusa board is not present on the board list of the Arduino IDE Arduino (1.0.5) ??

OS : Windows 8.1

Installed : NETMF and Gadgeteer Package 2014 R5

@ zakhounet - You need to install the Gadgeteering SDK, but we no longer host it. You can unzip into “My Documents\Arduino”. Make sure you have a folder path like “My Documents\Arduino\hardware\GHI Electronics\avr” (among other folders).

1 Like

Thank you John. I am all set now.

Does that means that GHI has stopped to maintain the Medusa S12, 3D, mini and shield ?

@ zakhounet - Regretfully that is correct, that line of products is no longer supported.