Main Site Documentation

Max Voltage on Serial In


#1

Hey guys, just a quick question, can serial in take 5V?


#2

Yes, as long as it’s not much more than that, and isn’t a shared analog pin.


#3

Thanks… Well in that case I’m having a rather weird problem - I try to read data from a serial pin and I keep getting just 0 - Funny thing is, it worked a second ago and I didn’t change anything… And the serial signal is still definitelly there…

Its connected to a radio receiver… Really can’t work out what could be wrong.

Also, any clue why

SerialPort radio = new SerialPort("COM2", 600);
            radio.Open();
            byte[] check = new byte[1];
            char[] ch = new char[1];
            while (true)
            {
                radio.Read(check, 0, 1);
                ch = Encoding.UTF8.GetChars(check);
            }

Throws an exception in mscore? Thats if the value actually ever gets read, which it currently isn’t. I’m really not having a good day :stuck_out_tongue:


#4

You aren’t using a full swing RS232 on one side, and the TTL inputs on the Fez side are you?


#5

Nope got it down to 3v3 now - So I have a 3v3 signal on the input line, not got an oscilloscope handy but when i turn on the transmitter voltage on that pin raises to ~3.27V, and when I turn it off it drops to ~1.3.

And all that time the panda is refusing to read any data - I would be happy with anything, even complete junk. Instead its just not reading anything - With the above code, it never gets to the UTF8 bit.


#6

I’m a little bit stressed out - this project is entering a competition tomorrow, and is going to get seen by hundreds of people. And it has decided to not work. Fml :slight_smile:


#7

Connect RX to TX then you can test that you can receive what you send.


#8

Good idea, thanks I’ll try that now.


#9

Loopback does indeed work. I guess it must be something with my radio module output - that’s strange, it worked just a minute ago :/.

What kind of problems would cause the controller not to get any reading at all from a serial pin? If it was strange/random data, that I could understand, but why might it get no reading at all?