Mainboard Missing From Wizzard


My name is Sots. Let me jump right in to the issue I am having. I recently bought a FEZ Raptor board and I am in the process of beginning to get ready to develop with it.

The problem is, after I’d follow all the steps from I cannot see the main board in application wizard! I have searched around in this forum and I can’t seem to find anyone with the same issue. See the attached image.

The closest suggestion I got from reading the posts here was to install the mountaineer SDK, which I have done, and then I was able to see the two mountaineer boards in the Wizard. After a bit of fiddling, I was able to write a ‘Hello World’ application which I have successfully deployed to the board and run it.

My configuration is set as per the instructions steps, VS2013 Community, .Net MF 4.3 QFE2, .Net Gadgeteer Core, NETMF and Gadgeteer Package 2014 R5.

I did uninstall everything and re-installed a couple of times now, but this seem to persist. What am I doing wrong?

Thank you all in advance.

Have you tried the gadgeteer book? Maybe you are missing a step somewhere?

Welcome to the community.

Hi Gus and thank you

Yes I did, actually that was my starting point. Right at this moment I am again trying to uninstall & reinstall everything… not that I expect to have something change, but I don’t know what else I can do.

I think the installation might have corrupted something somewhere. Is there anything I can do, or is there any manual installation of components I could go through?

I have been at it for 3 days now and no joy :’( :slight_smile:

@ MenaceFOP3 - try uninstalling all other NETMF SDKs like the the mountaineer. Search fro anything gadgeteer or NETMF and uninstall all.

“Step 3” on .NET Micro Framework – GHI Electronics is the important one for Gadgeteer support. Then, in Step 4, the GHI installer will install the actual SDK that has the mainboard definitions. You should be able to see a separate GHI Gadgeteer SDK installed in your “uninstall a program” list.


Thanks both Gus & Bret for their suggestions. after I’d have followed the steps in the guide “religiously” :slight_smile: - for 8-9 time I gave up.

So I’d started installing the relevant components described in the guide - .NET Micro Framework – GHI Electronics - but trying different versions of them. One of those did the trick, I will investigate which one (too many combinations to try I am afraid) and report back just in case my problem’s solution can help someone else to overcome this issue or something similar.

Now I have a different issue :S

I’ve created a new program as per the tutorial PDF and when I try running/debugging I get this:

However BOTH these assemblies are in the project with their correct respective versions. Tried removing them and re-adding them manually, but the issue persists.

Any ideas?

PS I do apologise acting like a newbie - but I guess I am one :smiley:

You said some version worked but what version? Have you tried going back to the latest SDK after now that it is working?

Yes I did :slight_smile:

as it stands now, I have:

 - NetMF 4.3.2 QFE2
 - .NET Gadgeteer Core 2.43.1000 - The same version BuilderTemplates under
 - NETMF and Gadgeteer Package 2014 R5

I am attaching the outputs below:

Micro Framework device deployment:



Something to do with the error maybe? Or the other way around?

you should now start the program FEZ Config and click the button >Check device for update<. If the firmware on the board does not match, you first have to deploy the new firmware version.
Cheers Roland

1 Like

This error you are seeing is due to your board not having teh firmware that matches what you are using on the PC. But the good news is that your PC seem to be setup correctly.

Update your firmware using FEZ Config please.

1 Like

Hi everyone :slight_smile:

Update on the situation. I downloaded NETMF SDK 2015 R1 Pre-Release 1 and after installation I’ve updated the firmware from version to version

It did rename the G400_Gadgeteer to G400_G400 (any idea how I can set this to something else?) BUT…

I wrote a quick “Blink LED” program for testing. I did need to re-point the Micro Framework to 4.3 rather than 4.2, despite doing that already in the initial mainboard selection screen in advance :think:

Build, uploaded and tested and SUCCESS!!! :dance: :dance:

It all works as I would expecting to, including debugger connection and breakpoints etc. 8)

I’d like to thank you all for your advice, it really helped point me to the right direction(s) :slight_smile: :clap:

Now on to some coding :think:

Great, now make something awesome and then share the video with everyone here :slight_smile:

1 Like

@ Gus - Will probably need a minute… :smiley:

…but that’s what the intention is :slight_smile:

1 Like