LED7R Module Constructor throwing CLR_E_PIN_UNAVAILABLE

I just connected a LED7R module to a Y socket, the following code is generated in the code behind of the visual designer:

led7r = new GTM.GHIElectronics.LED7R(14);

When the program runs, it throws an exception in this constructor:

[quote]Using mainboard GHI Electronics FEZSpider version 1.0
#### Exception System.Exception - CLR_E_PIN_UNAVAILABLE (1) ####
#### Message:
#### Microsoft.SPOT.Hardware.Port::.ctor [IP: 0000] ####
#### Microsoft.SPOT.Hardware.OutputPort::.ctor [IP: 0006] ####
#### Gadgeteer.Modules.GHIElectronics.LED7R::.ctor [IP: 0030] ####
#### MultipleTimeZoneClock.Program::InitializeModules [IP: 0007] ####
A first chance exception of type ‘System.Exception’ occurred in Microsoft.SPOT.Hardware.dll
An unhandled exception of type ‘System.Exception’ occurred in Microsoft.SPOT.Hardware.dll[/quote]

Any ideas why this is throwing?

What mainboard?
Tried other sockets?

Hi @ Gus - the mainboard is a Spider. I attached the schematic diagram of the build.

Here is the code behind:

// <auto-generated>
//     This code was generated by the Gadgeteer Designer.
//     Changes to this file may cause incorrect behavior and will be lost if
//     the code is regenerated.
// </auto-generated>

using Gadgeteer;
using GTM = Gadgeteer.Modules;

namespace MultipleTimeZoneClock
    public partial class Program : Gadgeteer.Program
        // GTM.Module definitions
        Gadgeteer.Modules.GHIElectronics.UsbClientDP usbClientDP;
        Gadgeteer.Modules.GHIElectronics.LEDMatrix LED21;
        Gadgeteer.Modules.GHIElectronics.LEDMatrix LED11;
        Gadgeteer.Modules.GHIElectronics.LEDMatrix LED22;
        Gadgeteer.Modules.GHIElectronics.LEDMatrix LED12;
        Gadgeteer.Modules.GHIElectronics.RFID RFID1;
        Gadgeteer.Modules.GHIElectronics.RFID RFID2;
        Gadgeteer.Modules.GHIElectronics.RFID RFID3;
        Gadgeteer.Modules.GHIElectronics.SDCard sdCard;
        Gadgeteer.Modules.GHIElectronics.WiFi_RS21 wifi;
        Gadgeteer.Modules.GHIElectronics.Breakout ledStrip1;
        Gadgeteer.Modules.GHIElectronics.LEDMatrix LED31;
        Gadgeteer.Modules.GHIElectronics.LEDMatrix LED32;
        Gadgeteer.Modules.GHIElectronics.LED7R led7r;

        public static void Main()
            //Important to initialize the Mainboard first
            Mainboard = new GHIElectronics.Gadgeteer.FEZSpider();			

            Program program = new Program();
            program.Run(); // Starts Dispatcher

        private void InitializeModules()
            // Initialize GTM.Modules and event handlers here.		
            usbClientDP = new GTM.GHIElectronics.UsbClientDP(1);
            RFID1 = new GTM.GHIElectronics.RFID(4);
            sdCard = new GTM.GHIElectronics.SDCard(5);
            wifi = new GTM.GHIElectronics.WiFi_RS21(6);
            RFID3 = new GTM.GHIElectronics.RFID(8);
            ledStrip1 = new GTM.GHIElectronics.Breakout(9);
            LED11 = new GTM.GHIElectronics.LEDMatrix(10);
            LED12 = new GTM.GHIElectronics.LEDMatrix(LED11.DaisyLinkSocketNumber);
            LED21 = new GTM.GHIElectronics.LEDMatrix(LED12.DaisyLinkSocketNumber);
            LED22 = new GTM.GHIElectronics.LEDMatrix(LED21.DaisyLinkSocketNumber);
            LED31 = new GTM.GHIElectronics.LEDMatrix(LED22.DaisyLinkSocketNumber);
            LED32 = new GTM.GHIElectronics.LEDMatrix(LED31.DaisyLinkSocketNumber);
            RFID2 = new GTM.GHIElectronics.RFID(11);
            led7r = new GTM.GHIElectronics.LED7R(14);


It’s failing on this line:

led7r = new GTM.GHIElectronics.LED7R(14);

With the exception I posted above.

I have tried both socket 14 and 12, since they are the only two Y sockets I have available. I wonder if the pins for these are actually being used by something else? As you can see from the attached diagram I have a lot of things plugged into this board.


Looks like a bug on our end but we will double check.

@ Gus, do you think this is something you guys will be providing a fix for in the next release, and if so when roughly do you think that might be?

I’m just trying to determine if I should expect this any time soon, so can build this component into an in flight project or not.

Thanks, Paul

Next release comes in Jan/Feb