Latest SDK 4.2 - An error has occured: Please check your hardware

There are several topics about this subject and I read them all. Nothing worked out.
These are the messages while debug process is ongoing:

The debugging target is not in an initialized state; rebooting…
The debugging target initialized successfully.

Then nothing happens but 1 error: An error has occured: Please check your hardware

I already installed .NETMF SDK 4.2 QFE2
I am using FEZ Hydra. I installed step 2, 3 and 4 from (latest version 10-24-2012)
I am using Visual Studio Ultimate 32-bit
I am using power hub with 9V 1A adapter.
I changed my system locale into English.

NONE of these steps solved my problem. I create a new 4.2 gadgeteer project and only write


for testing purpose but nah… I still get this error. It’s been 5 days since I got my new Hydra and I can say that I greatly regret that I chosed Hydra instead of Spider… There is no such ambiguous errors in the forum for Spider…
Anyway, please help me
Thank You,


What OS are you using? VM?

What does the device manager say?

Have you tried another USB cable?

I am using Windows 7. Here is my device manager image.

Update your firmware please.

Already done. Here…

Strange! Do you have the latest SDK?

Yep, I have SDK 4.2 QFE2 and installed GHI products from “GHI NETMF v4.2 and .NET Gadgeteer Package (10-24-2012)”

Then you did not update the firmware :slight_smile:

The new firmware uses a different driver which I am not seeing in your device manager.

Wow… I thought I had completed the update through deploying the files in Non Ethernet file. So can you please tell me what do I need to do extra?

I just realized this is hydra. Then what is in your image is correct.

The only thing left is power and USB.

And I just realized I ruined my DP module by trying 12V, it’s smoke is still in front of my eyes…
Nevermind I was always the unlucky person with hardware stuff. I think I need to order another DP module.
Thank you for your help.

The module will run at 30V!

Nevermind its my bad. I tried HAMA usb hub with 12V. It is a good brand but I think it couldnt handle 12V and somehow damaged my module, and also turned out my mainboard…