Issues with Windows10/NetMF on Raspberry Pi 2

Hi guys

OK, so I downloaded windows10-for-devices build 10049 (Arm) and followed the release notes to make a bootable flash card for my Raspberry Pi 2. After finally getting the partitions correct, and getting USB and HDMI to work properly, I first ran into issues with Wifi. No matter what I do, I cant get w10 to recognize any wifi dongles on the rpi’s usb ports. Has anyone else had that issue? Or gotten one to work?

But after giving up on that, I was able to install vs2015 and NetMF (over ethernet). The gadgeteer core didnt install though. (I expected that, but it was worth a try)

But using pure NetMF Ive had marginal success with the different modules Ive tried. Button, LED7R and joystick modules work as expected just using the pins directly. I really have no idea how to use the Smart LED Module using pure NetMF though. Do I need to wait for a GHI DaisyLink Driver?

I also tried using the PWM pins on the rpi with a DFRobot servo extension module and some SG90s but no luck there at all. Has anyone else gotten very far with this? Is there something different about PWM in windows 10 for devices?

Anyway, I’m anxiously awaiting GHI’s Gadgeteer “HAT” and core for this thing!


@ mtylerjr - Where did you download the image from?

1 Like



Impressive feat getting as far as you did. Is the ARM version what they are calling Win10 IoT? GHI and possibly others here are working with this, but I’m guessing are under NDA for awhile longer.


April 1st post



At first I was all :open_mouth: but then I realized this was an April 1 post. Phew!

FWIW, I’m working on this today (mostly complete, but have some more wiring to do, and will probably mount a holey board on top when that arrives, and some LEDs), and I can tell you that bits are obviously not yet ready/public for the Pi 2. When they are, though, this little guy will be waiting. :slight_smile: We’ll say more at Build.

Sorry for the bad staging. My poor JD-800 is a table at the moment, so it seems.

Current BOM:

DF Robot Devastator Tank Mobile Platform (this takes a couple distracted hours to assemble; less if you aren’t helping your son build a trebuchet at the same time)

6v NiMH rechargeable battery pack from Robotshop (for motors – the kit comes with a holder for 6 AA batteries --9v total)

5v rechargeable battery pack (for Pi 2)

Raspberry Pi 2
Gadgeteer Hub
Gadgeteer HAT prototype
Motor module
Switch with leads, some additional wire, etc.
No sensors or communications just yet because, you know, WiFi isn’t working. :smiley:
A couple zip tiles to hold the 5v pack to the underside.

Don’t buy anything, though. I haven’t any idea yet how much of this will actually work. :slight_smile:

And yes, the makeblock is likely to be a second robot. Muah hahahaha!



@ Pete Brown - that girl’s got a nice track! :wink:

Thanks. I’m not a fan of those cheap yellow motors that show up in every chinese robot kit, but at least this one doesn’t also have the cheap yellow wheels. :slight_smile:

It’s actually a pretty decent kit for the price. I was surprised.


I think your pictures do it more justice than those on DFRobot. It looks very small in their pics.

That is an awesome looking rover!

I’m just waiting for my raptor to come back to finish mine… but you’ve made me think about possibly retrofitting it for my Pi2 in hte future.

Although I’d have to rename it…

I used the yellow plastic motors originally, but they weren’t good enough, so I got some good metal gear motors and some meccanum wheels.

Mine wont be able to traverse the terrain that yours can… but It will be able to go sideways!

That power pack looks awesome. I wish I could order those here, but shipping lipo batteries is a problem. All I can get are cheap chinese alibaba/dx packs with extremely questionable specs…

That’s yet another project on my projects list! The trouble is that my list is a lot longer than the time available. :’(

You can always try a SmartBluetooth module from @ Justin connect it to a uart socket or use a BLE dongle (if working of course) and control the robot thru a universal phone app.

Assuming you have a wp avail.

Thanks. I was mostly commenting on the April 1 post at the start of this thread, where he said WiFi isn’t working. :slight_smile:


1 Like

@ Pete Brown - Well, in that case you got me fooled … :smiley:

1 Like

I still want to know what Brett posted, before he deleted his comment :smiley:


You’ll need to pay me a lot to get it back :slight_smile: