Issue with Ethernet module J11D

I have noticed that only the green led on the module is turned on. My code is as follows:

    public partial class Program
    {
        // This method is run when the mainboard is powered up or reset.   
        void ProgramStarted()
        {
            ethernetJ11D.UseDHCP();
            ethernetJ11D.NetworkUp += new GTM.Module.NetworkModule.NetworkEventHandler(ethernetJ11D_NetworkUp);
            ethernetJ11D.NetworkDown += new GTM.Module.NetworkModule.NetworkEventHandler(ethernetJ11D_NetworkDown);

            // Use Debug.Print to show messages in Visual Studio's "Output" window during debugging.
            Debug.Print("Program Started");
        }
        void ethernetJ11D_NetworkDown(GTM.Module.NetworkModule sender, GTM.Module.NetworkModule.NetworkState state)
        {
            Debug.Print("network down");

        }
        void ethernetJ11D_NetworkUp(GTM.Module.NetworkModule sender, GTM.Module.NetworkModule.NetworkState state)
        {

            Debug.Print("Network Up!");
            Thread.Sleep(200);
            string sIP = ethernetJ11D.NetworkSettings.IPAddress;
            Debug.Print(sIP);
          
        }
    }

And the network up event isn’t called, only network down is called. Can you suggest what is the issue?

@ bioengproject - Review the Gadgeteer source code for the J11D. It is possible that the network up event does not occur when the network cable is plugged in at initialization.

@ cyberh0me - OK, removed the thread.sleep, and the Ethernet cable used to be plugged anyway and anytime so i don’t think it’s related.
Why the orange green isn’t turning on?

Even replaced the main board with another main board, issue remains

@ bioengproject - The built in Ethernet LEDs did not function until the 2016 R1 Pre-Release 2 SDK. Can you test with that one?

@ bioengproject - OK GHI,
I checked it, on 4.3.1, I don’t get IP on the Ethernet module but on 4.2.11.2 I do get (same Ethernet module).
(I have two same systems, connected to the same ethernet port with the same cable and i took the ethernet module from one system to another)
The orange led isn’t blinking on both system but on the 4.2.11.2 i do get IP.
Could it be issue on the framework or something? Not sure what to do.
Can someone from GHI contact me?

@ bioengproject - I just posted myself a question on the forum. In my code i initialize the ethernetJ11D module on a Spider Mainboard. I have no problems with the module and the leds work.

@ RoSchmi - On which framework?

@ bioengproject - NETMF 4.3, GHI SDK 2016 R1 Pre-Release 2, Spider Mainboard

@ bioengproject - did you set a correct and different MAC address on each of your mainboards?

@ RoSchmi - Not sure I understood, can you elaborate?

@ cyberh0me - How do I do it? I never done this before, could it be the reason it’s not working?

@ bioengproject - You can use FEZ Config or MFDeploy. On FEZ-Config go on Network Configration and set the MAC Address. If you don’t have a special MAC-Address which was delivered with your Mainboard, it seems that you can generate one with FEZ Config. If you have more than one Mainboard with the same MAC Address in your network your router will have problems to know which IP-Address was assigned to which device

@ RoSchmi - OK, so I opened FEZ->network configuration->Load built-in Ethernet Config and then Apply built-in Ethernet Config.

Should it work now?

@ bioengproject - No, I don’t think so. Note (remember) the MAC you loaded from the device by “Load Build-in Ethernet Config” . Then click Generate MAC Address, then store this MAC Address to the device. Load it back to verfy that it worked

Still not getting ip, although the green led is blinking rapidly,
I am sure it’s not hardware fault because the same ethernet module works with another spider on 4.2 framework.
Could it be related to the bootloader? (Version 4.2.11.0)

yes, get bootloader and firmware on the same level (always!)

@ Brett - But why would it be related to the IP?
And, can you find me a tutorial on that??

Here is a fun fact, I tried updating the bootloader using FEZ->Advanced->Update boot loader.
I changed the 1-2-3 switches to on, reset, and then back to off and tried to go on with the procedure and now the spider isn’t getting recognized by windows 10.

Is there a way to restart the mainboard somehow ?