Main Site Documentation

ISOx16: Connecting 12v causes relays to chatter


#1

I have been doing some tests with my new ISOx16 Relay module and have discovered that if the 12V connection is powered without the gadgeteer socket being connected, the relays chatter (not sure if this is the correct terminology but sounds as if they are being driven by AC instead of DC).

Have tried two different 12V power supplies with the same result.

If the module is connected to my Cobra II, then the module seems to work as expected and I am able to turn relays off and on.

I’m hoping that this is a faulty module rather than the possibility that the small gadgeteer interface circuit is inducing this symptom when not connected to a socket on a main board.

Can anyone confirm if other ISOx16s do the same thing or if this is likely to be a faulty module or quirk with the power supplies I have tried.

Cheers,


#2

This is possible as the design is done to work only with mainboard connected.


#3

This is a “to be expected” condition. If a mainboard is not connected, then the input(s) are floating and are seeing noise etc. This type of a problem is usually fixed by adding a pull-down resistor to the input(s);


#4

Thanks for the quick replies.

@ Mike - Looking at how the the interface board is attached I may be able to stack another smaller board with pull down resistors on top of the connector to the relay board. I have 1K, 10K and 4.7K resistors somewhere here - would any of these be suitable?

Cheers,