Main Site Documentation

Is there a way to get Gadgeteer working with VS 2015 Preview?


#1

On the Support page it said, that it would work with the VS 2014 CTPs, so it should be working with VS 2015 as well, right?

So followed the Steps on the Support page and installed .NET Gadgeteer Core 2.43.1000, .NET Micro Framework V4.3 SDK-R2-Beta and the GHI NETMF and Gadgeteer Package 2014 R5, but I can’t seem to find the Gadgeteer Template in VS.

Any Ideas ?


#2

Anybody have an idea how to get it working ?


#3

Welcome to the forum!

If nothing works you can always recompile Gadgeteer yourself.


#4

@ Architect - So technically it should work, right ? Is there maybe a way to manually add the Gadgeteer Template to VS 2015 ?


#5

depends. If you want the tools to work as they work in VS2012 today, and can’t accept anything but, then stay in VS2012. There are many moving parts here and not all of them support later VS versions, so you shouldn’t just expect plain sailing.


#6

Well, I tried it, with Raptor, Spider, Cerbuinos, Cerberus’ and maybe more can’t remember. Than, my harddisk broke up and all VSs died on me, so I had to set it up again. With 4 VS versions maybe not a surprise so I setup now only VS2013

Didn’t try to copy over the gadgeteer and see how far I can get in VS2015. There are various entries here by me that show the workings.


#7

I have MSVS 6.0, 2008, 2010, 2012, and 2013 on my main development partition (win 7) and vs 2014 and 2015 on my windows 10 “play around” partition.

I still have to use 6.0 for some legacy stuff… can’t get rid of 2008 either, for legacy windows mobile 6.0 stuff. 2010 is looking like a candidate for uninstall though.