Main Site Documentation

Is my Raptor DOA?


#1

I just got my end of year items from GHI. One of hte new items I got was a FEZ Raptor. However, I can’t seem to deploy anything to it. It always fails. The device shows up as G400_G400 in Visual Studio, FezConfig and MFDeploy.

From FezConfig and MFDeploy, just doing a simple “Get Configuration” seems to lock up the program for a few minutes, and am told the device is not responding.

I also have a new Cobra II board that works just fine, so I know its not the cables or the USB port. I have tried connecting the Raptor via both an USB-Serial SP and DP module. No luck with either.

Any suggestions?


#2

Have you tried to upload FW and boot loader again?


#3

@ RoySalisbury - What method are you applying power to the Raptor? What is the USB port type, 2.0, 3.0? Is it on a powered hub or straight from PC? Is it a regular PC or a VM?


#4

Documentation for the above two posts:

updating the Loader https://www.ghielectronics.com/docs/236/loader-tinybooter-update-g400

Based on your success with Cobra II, USB may not be a problem. But the power level of the USB may still be a factor (unlikely, but possible in borderline cases). For potential USB issues, and other helpful hints try: https://www.ghielectronics.com/docs/165/netmf-and-gadgeteer-troubleshooting


#5

Its a USB 3.0 Port direct off the computer. The system is actually one of the latest Mac Mini’s.

Currently I am using a Paralles VM off my Mac, but I just setup my MacBoox for Bootcamp again and will try it native once I get everything installed.

I have also tried powering the board off a 9v and 12v power supply as well just in case the 5v was not enough. No other modules were connected during my last try (other then the USB client).

I downloaded the AmTel stuff and re-flashed the TinyBooter per the instruction on the site and that went fine. But once it was done, still no luck.

Roy


#6

OK… My new install of Windows 7 x64 with Visual Studio 2012, NETMF 4.3 and GHI SDK (R3) is complete.

I was able to connect Fez Config, ping the device and update the firmware without issue. I was then able to deploy a simple “debug.print” application.

So it seems that it is either the USB 3.0 ports or the Virtualized/Pass-Thru USB ports to the VM that the Raptor does not like. It works find for the EMX boards and the Cobra (G120), but the Raptor (G400) does not like it. Might be a timing issue.

I’ll stick with my laptop in Bootcamp mode for all my NETMF development (I can just remote in from my main system, so its not an issue).

Roy


#7

@ RoySalisbury - There seems to be some issues with USB 3.0 for all of the NetMF devices.

There may also be some issues with the VM, possibly specifically with Atmel chips (although unsubstantiated). We had an issue with Hydra and VM, of which Hydra is an Atmel chip.


#8

In the past, I posted about my experience with the Raptor and a VM. While all the other Premium boards work with the VMs, the Raptor does not. Also, I have not been able to get a OSHW board to work with a VM. As Aron said, it might be chip related.


#9

Fired up my new Raptor tonight and was having the same problem, which is weird as I have been using this rig for Gadgeteer development for some time without any problems. So first I reflashed the firmware and then I rebooted my system and it started working (maybe a USB driver issue which needed the reboot), but that worked for me and I’m now happily coding and debugging away with this Raptor.

I’m using one of these as my powered hub http://www.thinkgeek.com/product/e2d2/?srp=5