Main Site Documentation

Invalid native checksum: GHIElectronics.NETMF.System 0x74883E49!=0x1832794B


#1

I have a simple application for the .NET micro framework 4.1
As soon as I add a reference to GHIElectronics.NETMF.System and try
to deploy I get some weird errors:

I have uninstalled and reinstalled the 4.1 SDK, but it does not seem to help.
When I remove any reference to that assembly I can build and run the app again
but of course then I have to disable the code that uses it.


#2

I feel a bit stupid for asking this. But you have uploaded the last firmware and verified it with mfdeploy? And thats corresponding with the build of your references?


#3

I believe so, as I only experience this problem on one machine,
however, I can check all of this again. I’ll download all the latest files from the GHI website,
try to use MFDeploy again… if it still fails after that, I’ll be back :stuck_out_tongue:


#4

Maybe your FEZ has the latest firmware but your machine has on old SDK


#5

I ran into this issue. it was the firmware on my device that was old. I deployed the new firmware on the device. and it worked fine. then upgraded the othere machines i have to the newest firmware.


#6

Upgrading now… the release notes said 4.1.0.1 while my device had 4.1.1.0 and the firmware in the sdk (with the release notes I just mentioned) actually have 4.1.3.0 :stuck_out_tongue: