Main Site Documentation

Invalid native checksum: GHIElectronics.NETMF.Hardware


#1

Hi GHI :slight_smile:

Link failure: some assembly references cannot be resolved!!

I have this error on adding GHIElectronics.NETMF.XXX.dll.
(After downloading Graphical demo application - I cant deploy it) Ive tried to remove and add references - no affect.
My TinyCLR version is 4.1.6.0 - and dlls 1.4.8.0 as I can see.
I found one dlls sequence that works, but a don`t understand why.
Can anyone tell me what this error means? And how can I resolve this issue.

Thank you
L


#2

Please check out #1 tip shown when trying to create a new topic.


#3

Tip #1 is read pointer #1 that is here where you entered this post. You MUST get the firmware on your device to match the SDK version you have installed. Then, if you have used an existing project, you need to open that project, remove all existing references, then re-add them which gives you the latest versions and everything should work.


#4

Hi, thank you for a quick reply.
Ive already tried it. My versions seems to be sdk compatible. My problem is, that maybe there are some dlls dependencies or linker adding assemblies order that I dont understand.
For instance - after adding all Microsoft.SPOT.XXX and GHIElectronics.NETMF.XXX
I want to add GHIElectronics.NETMF.IO.dll - and… I got this error.
Thank you…
L


#5

what is the error exactly?


#6

Firmware update.


#7

Doh, It was in the title.

Yeah, What Gus said :slight_smile:


#8

If you re-use someone else’s project file or open an old project that you used with an older firmware version, instead of creating your own new project and copying code into it, then you have to remove and replace references.

If you continue to have problems, you should show us the output of the Device Capabilities in MFDeploy and confirm the versions listed in the SDK Readme file.


#9

Hi.Thank u all.

This is from SDK

Version Info

Important note: Requires .NET Micro Framework 4.1 and Visual Studio 2010

• USBizi (FEZ Mini, FEZ Domino, FEZ Rhino, FEZ Panda) V 4.1.8.0
EMX (FEZ Cobra) V 4.1.8.0, TinyBooter V 4.1.6.0
• ChipworkX V 4.1.8.0 TinyBooter V 4.1.5.1
• GHI NETMF Library V 4.1.8.0

I have emx development board with 4.1.6.0.

[b]dlls Im using 4.1.8.0 [/b]What is it that I dont get?

L


#10

You have not updated the firmware on your EMX. It needs to be 4.1.8.0, not 4.1.6.0 that you say it has. That is all. Do that properly and everything should then just work correctly.


#11

III,

If you use the EMX Updater utility from GHI, and click both these menu items:
Device / Get TinyBooter version
Device / Get Firmware version

You should see the current versions on your board (see screenshot).


#12

Thank you so very much !!!
Firmware version 4.1.8.0
Working like a charm :slight_smile:

L