Introducing Secure Assemblies

Originally published at:

Introducing Secure Assemblies

In today’s release of preview 6 of TinyCLR 2.0, we are glad to bring you the all-new “Secure Assemblies” feature. Security is one of the main foundations of TinyCLR 2.0 and the SITCore (Secure IoT Core) product line. So, when we decided to introduce support for external flash, we had to go back to the drawing board. External flash is not secure by nature. A hacker can always access the data in and out of the flash with a little of work. Thankfully, we have plenty of internal flash that is very difficult to be accessed by unwelcomed users. The solution was in labeling important assemblies as “secure” for Visual Studio to make sure they are only loaded in internal memory. It then allocates the remaining assemblies as needed. While this was a simple solution on paper, it turned out to be quite complex and it required to change everything, from Visual Studio extension, to firmware to Config tool. So, go ahead and try it now. You simply need to add “Secure” to the AssemblyConfiguration in the “AssemblyInfo.cs” file.

Once you have installed everything preview 6, you will notice more messaging while deploying to your device.

TinyCLR Config tool also now includes Deployment Map

And it also includes device configuration


I installed v2.0.0.0 preview6 on SC20100 and SC20260 and it seems to work but I have the error below at the end of the download.


Connexion is good after download and it is possible to transfer a program with Visual Studio .

Update was tried with two PCs, several USB ports and different power supplies. I did not find any information about TinyCLR Config errors on

Same here.

1 Like

We know why you are seeing this. Preview 6 updates the system boot configuration and when it does it requires manual reset. You will see this error only once, never again!

Can you confirm that you do not see this error again please?

Not confirmed on my side :frowning:
Both in firmware and loader modes.

But it does not seem to prevent the board from working.

1 Like

Hello @Gus_Issa,
If I download only: I always have the same error but if I delete everything then I download:
the first time: error,
the following: ok

1 Like

Can you try to disconnect power and reconnect instead of hit reset button?

I did it. It does not change. But as @Bec_a_Fuel says, it seems to be working.

after you got it working, is it still happened?

I mean, you have to “erase all” every time update firmware?

Yes. I have.

I installed v2.0.0.0 preview6 on SC20100 and SC20260 and everything was ok

and i am not facing error from above reported

Everything was ok and show me green colour - Connected …

update i did through USB port not from VCOM !!

Does it require Erase all always, even without application?

yes, it does

Can you tell us the bootloader version please?

To clarify, hold LDR button down, reset the board and then click connect on TinyCLR Config. What version do you see?

Loader is v2.1.0

Not sure, I just tried back 2.1.0, could not reproduce. :sweat:

this does not seem to affect the functioning of the applications