Main Site Documentation

Installation Problems


#1

I am attempting to follow your installation instructions.
Step 1 was install VS, and the .net micro framework. That is done.

Next was to install the GHI NETMF v4.2 and .NET Gadgeteer Package (04-30-2013).
Done.

Next it says start VS and look for Gadgeteer templates. I don’t see any. I don’t see any in the search results either.


#2

in VS under File > New> Project select a new C# project and select Gadgeteer 4.2


#3

Right, except that mine does not offer that choice.

I closed, then re-opened VS and now the Gadgeteer templates appear. Magic.

The installation instructions are very old, and don’t reflect all the VS2012 differences.

Moving right along,
Thanks.


#4

Another place to look for help/guidance: http://www.ghielectronics.com/docs/43/first-gadgeteer-project


#5

Fine, but the Cerb40 does not appear in the designer.


#6

The cerb40 is not a gadgeteer board it is a plain Netmf board
if you want a gadgeteer board you need the http://www.ghielectronics.com/catalog/product/349
you can use the FEZ Cerberus Mainboard in your project but you will have to wire up all the sockets manually


#7

so, where to start then?

First Cerb40 project in VS?


#8

The visual [em]Gadgeteer[/em] Designer only shows [em]Gadgeteer[/em] modules and mainboards. The Cerb40 will be a NETMF project in Visual Studio. You might want to start with http://www.ghielectronics.com/docs/21/first-netmf-project


#9

All sorts of problems with that.

The first demo program doesn’t do anything to the hardware. Nothing at all.

The Blink an LED example uses expressions which are incompatible with this hardware:
LED = new OutputPort(EMX.Pin.IO47, true);

Aren’t there examples for the hardware I purchased?

Otherwise, where is the programming guide outlining all the functionality pin by pin, register by register?

Beginning to think there is a huge disconnect here.


#10

All boards share the same libs, the same knowledge. The pin numbers are printed right on the board. The led blink code works, just change the pin to he one you need.

Do not forget to add GHI.Hardware.FEZCerb, which has the pin enum.

The beginners guide ebook ok “first NETMF project” is what you need to get started. It should be all easier once you have an LED blinking.


#11

Let’s recap where this problem stands:

Using Gus’ advice and referencing Framework 4.2 instead of 4.3, the Reference Assemblies now appear. That means the 2nd beginner project under Next Steps: Digital Input, will build and compile.

Moving on, if either project is built and deployed via USB to the Cerb40, V4.0, I get this response:

Looking for a device on transport 'USB’
Starting device deployment…
Iteration 0
Opening port \?\USB#VID_1B9F&PID_0102#6&3532c170&0&1#{09343630-a794-10ef-334f-82ea332c49f3}\Operations
Attaching debugger engine…
… debugger engine attached!
Querying device assemblies…
Waiting for device to initialize…
Waiting for device to initialize…

Seems like we are close to a solution?


#12

what is the version number of your loaded firmware. Use fez config to see it.

Have you looked at the troubleshooting guide?


#13

You mean this troubleshooting guide?

Following this other guide http://www.ghielectronics.com/docs/165/netmf-and-gadgeteer-troubleshooting, We reach this point:

Warning
If you see “TinyBooter” after “Pinging…” instead of “TinyCLR” then your device does not have all the software loaded on it. Please follow the Firmware Update document for full details.

Which leads us to re-install firmware::
http://www.ghielectronics.com/docs/55/firmware-update-fez-cerberus
installing this: (a repair, since I did this three days ago) DfuSe_Demo_V3.0.2_Setup_amd64.exe for 64 bit OS

and this, which displays no feedback: dpinst_x86.exe
This is all under “Before you update”… :frowning:

Okay, on to STDFU Tester:
Step1: not my unit, ignore.
Step2: Does it boot? It does not. Devices block is blank.

Ok. There we are.


#14

Can’t say I’ve gotten a pin to as much as toggle yet, but I think I’ve managed to get VS to deploy to the device. How you might wonder? Me too!

I had hit that impasse where the Troubleshooting guide said to upgrade firmware but the STDFU Tester reported no devices attached. Tried it on a totally different machine and installation too.

I skipped way down that page to Load TincyClr and followed the install non-Ethernet path. That used MFDeploy.exe, which at least would recognize the USB and the device. I installed the firmware.

After that, the STDFU Tester STILL shows No Devices. (not a good sign)
but the MFDeploy.exe reported TinyClr rather than TinyBooter. So that seemed good.

I ran VS with a default console .net micro template, changed the Debug line to something with many colorful metaphors, and hit Start. Out they popped on the Output.

So… Sounds like it should be working theoretically… That guide need a major overhaul…