Main Site Documentation

I'm probably an idiot - firmware upload problem


#1

I’ve just received my Domino in the mail ;D download the .NET 4.0 sdk, download the GHI latest firmware, check the device capabilities (4.0.3.0), but only 4.1.1 is available at GHI, so I guess I need to upgrade the firmware. So download .NetMF 4.1, download Teraterm, switch Domino into loader mode (fails often - USB Device not recognized), but is successful 50%. System|Device Manager tells me that GHI Boot Loader Interface is on COM3. Set up Teraterm to talk on COM3. But sending command V (or in fact any letter) just echoes the letter, no other information comes up. And Teraterm will also echo the letter if the Domino is disconnected.
So what am I missing?


#2

capital X for uploading mode…

anyways it says “bad firmware” when I tried to upload the new one. Just got it today!


#3

Maybe the power source from the PC is not sufficient. Please use power pack for now or connect FEZ directly to the PC, HUB…or use a powered hub.


#4

Getting an invalid response to bootloader commands is also possibly an indication that you have something not connected right (or possibly you are hitting the wrong com port?). If you don’t get the BL responding properly, there’s no point trying to do this.

You can use the Fez Panel http://ravenlabs.org/storage/TinyCLR/FEZPanel.exe to do the uploading etc, much more fault tolerant than Terror Term (deliberate mis-spelling :slight_smile: ).


#5

I am using a power wall-wart (plus a powered hub). your URL for FEZPanel returns a very ugly 404 page. And I’m used to Teraterm – have used older version on some other jobs. I’m also sure I’m using the correct COM port (as proven by Device Manager (see att. photo)


#6

Maybe windows virtual com drivers is locked up? Try reset?


#7

http://ravenlabs.org/downloads.php?cat_id=1&download_id=18 Thats the correct ink for FEZ Panel.


#8

Unfortunately FEZ Panel bombs with a null reference exception. I will reboot now…


#9

That sure looks like the COM port is locked up. A restart may help.


#10

Fascinating…
There’s a bug in the serial driver being used… I’ve tried different COM numbers (can be set in advanced in the GHI Boot Loader Interface through Device Manager). When I changed it from COM3 to COM41 and then back again, and then tried to open it in FEZ Panel with COM41 still, then it worked. So it’s almost like the GHI boot loader driver either uses the previous setting or some other thing like that.
Anyways, the FEZ Panel is now talking to the domino!!!

Cheers


#11

Skip the “probably” in the subject :). All problems went away when I bypassed the hub and plugged the FEZ Domino into my machine directly.
Thanks everybody for your help. Now on to writing my first FEZ program !!!


#12

Awesome good to hear.