I think my Cobra II Died

I can’t get my Cobra II to respond to anything. It will not connect to my computer, no com port. Subsequently FEZ.config does not see it nor can TeraTerm. I have tried the LDR0 & LDR1 down and pressing reset, pressing reset by itself, doing the same while powering up and grounding the reset pin. I have checked the buttons and they are functioning properly. I have tried powering it with external power and with the usb connector. My Raptor and Hydra connect fine. I have rebooted the computer with no luck. The power led is on bright and the led1 in on dimly.

It is on Firmware and Loader when I last could communicate with it.

Is it time for the grave?

open device manager. make sure you have sounds turned on. connect the Cobra2, tell us does it make a device connected sound? If so, what device appears in device manager?

Brett, that is what I meant when I said no com port. No sounds, nothing in device manager or devices connected. It is like the usb port on the Cobra has failed. I tried different cables to no avail. There is simply nothing to connect to.

@ CDR114 - Can you put it in serial debug mode and try to talk to it over COM1?

@ John - I am puzzled how to do that.? Since the computer does not see the cobra in any manner, no ports appear in the device manager except the standard computer serial port defined as com 1, I can’t set the terminal to the com 1 port because the output would be directed to the 9 pin d-sub on the computer. If the cobra had a 9 pin d-sub I could connect it to the com 1 port on the computer and see if that works, but the cobra only has the usb connector. I don’t expect the gadgeteer serial module would be of much use. Could I use any of the exposed pins?

I am wondering if I got the Cobra into some sort of tight loop. Prior to the board going out, I was having issues with the joystick module functioning properly with 3 serial modules attached. I have the Cobra Extender Board. So I was testing to see which ‘U’ connectors was causing the issue. So I wrote a simple program that had just a joystick event that when triggered would print the x and y coordinates out in debug mode. Two serial modules connected, everything worked fine, but three didn’t. I would just get 0 and 0 no matter where the joystick was positioned even though an event was triggered. I was powering the board on and off by unplugging the sub connector and then changing which ‘U’ and ‘A’ connectors I was using. However, one test resulted in the condition I am at right now.

Or could I have had a static discharge that zapped something when I plugged the power back in. This was all being done at my home, which doesn’t have any static discharge protection.

@ CDR114 - I mean COM1 on the Cobra. Put the board in serial debug mode then connect COM1 on the Cobra to your computer using the Gadgeteer USB to serial module. COM1 is on socket 5 and you can find the MODE pin for serial debugging on the header.

it is possible a tight loop caused an issue, but in all honesty it sounds like you weren’t testing additional code at each iteration of the above tests, so I’d doubt code that worked once would then cause a tight loop and to not see any device in device manager. The mode pin test for serial debug is definitely something I would try, and see if there’s any data coming from there (although if you were playing with serial port code, that might be “interesting” conflict; perhaps it’ll just throw an exception and move on).

And yes it’s possible you have caused some other electrical fault on the device. One thing I would do, based on your description, is go around all the sockets you’ve been using and make sure none of the pins are bent or have foreign objects in them. It is also possible that something like that could be causing a power issue/short.

@ Brett - I don’t have the USB-Serial SP Module, so I used the RS232 module connected to socket 5 then with null modem cable to the 9 pin d-sub, com 1 on my computer. I jumped pin 13 (mode) and pin 5 ground. I could not get any response with TeraTerm nor with Visual Studio set to serial transport mode. I don’t think it is correct, but I also tried a straight cable, with no results.

Therefore, it must be dead.

Does anybody need a nice custom 3d printed enclosure for their cobra II. It is setup for a joystick, n18 display and 3 rs232 modules and the cobra extender?