Main Site Documentation

I get an error I don't understand


#1

Hi All,

Apologies for the complete noobness. I’m fumbling my way around C# for the first time ever, so don’t really understand what I’m doing. Trying to follow the example in the “getting started with the FEZ Cerberus kit” examples. But I consistently get an error that says “Reference to type ‘LCDRotation’ claims it is nested within ‘Gadgeteer.Modules.Module.DisplayModule’, but it could not be found”. It mentions the file “GHIElectronics.Gadgeteer.FEZCerberus.dll”. I have no idea how to get rid of this error, nor how it got there. I have been fooling around with the Designer, and added my TE35 module to it, but I have removed it now. I can’t see any references to anything LCD related, with the possible exception of some using statements that mention Presentation. I tried commenting all these out but the error remains.

All advice gratefully received.

Ian


#2

I would try to start a new project. Would probably make it easier.


#3

@ rcplaneguy -

All display modules DLL are in C:\Program Files (x86)\GHI Electronics\GHI .NET Gadgeteer SDK\Modules (if you did not change the installation directory). But normally, it should have been added to VS Librries by default !

Have you created you project from scrash, or download from somewhere on the forum ?


#4

@ rcplaneguy: That usually happens when a library isn’t referenced.


#5

RCPlaneGuy, welcome to the forum, and welcome to another Aussie ! Hope the model shop is going ok - can’t say I have bought any model gear recently, probably spend a little too much time here :slight_smile:


#6

Hi All,

Thanks for the advice and encouragement!

I tried creating a new project as Architect suggested. All I did was start a new project, then add the power supply (UC_battery_4xAA) and the joystick. I connected the power supply and joystick to the main board.

Went to program.cs and pressed F5, and the same error message about LCDRotation appeared. But I dug a bit deeper this time and had a look at the output messages. There are a few that concern me ever so slightly. The first one is “ERROR!!! Firmware version does not match managed code version!!!”. Then it says “Invalid native checksum: GHI.OSHW.Hardware 0xF0D4135D!=0x52D307E9”, then “Resolve: unknown type: Microsoft.SPOT.Touch.TouchScreenEventHandler” which I’m guessing might have something to do with the LCDRotation error. But it seems if I can fix the first error the rest of them might go away. Do I need to reinstall my software, or reflash my hardware?.. I’m lost.

Ian


#7

Ah, that’s the “firmware mismatch” issue.

All you need to do is deploy the firmware to your Cerberus.

Instructions here in a second… I’ll be back :slight_smile:


#8

http://wiki.tinyclr.com/index.php?title=Firmware_Update_FEZ_Cerberus

Step through that.


#9

If you effectively use the OSHW 4.2 SDK, you need your board firmware to be upgraded in NETMF 4.2 QFE2 (see on GHI Website for the several SDK :

http://www.ghielectronics.com/support/.net-micro-framework

You need to add a reference to Microsoft.SPOT.Touch in your project references.

But as you said and is right : Starting by solving the versioning problem will solve a lot of subsequent problems…


#10

Hi Brett,

Started doing the update, the driver install either did nothing or finished very quickly. But then got stuck here

"The USB drivers should be installed with the GHI NETMF v4.2 and .NET Gadgeteer Package installer, as Step 7. If necessary, the drivers can also be installed from Package -> Installation Files, as GHI NETMF USB Drivers x64 (or x86 depending on your processor). Install the appropriate msi file to load the drivers into Windows. "

What does it all mean?..


#11

@ andre.m -

Hey Andre, what about your avatar ? DId you leave Ossie for Aussie :wink:


#12

Sorry, getting a bit tired, been at this for a while now. What I meant was not what does it all mean, what I really meant was how do I do it. I don’t know how to carry out the instructions. i.e. how do I install the USB drivers using the GHI NETMF v4.2 and .NET Gadgeteer Package installer, as Step 7. Where is the package installer, how do I start it? What are steps 1 to 6? Can I just skip them? All I’m trying to say is that the instructions are not very clear at that point in the Wiki for people like me who basicaly have no idea what they are doing.

Apologies for being so basic, electronics is not my thing really. I understand programming (used to be a Cobol programmer when Jesus played full back for Israel), and I’ve coded a fair bit in C# like code using a stock trading tool called Ninjatrader, but that’s about it. Ask me anything about model planes…

Thanks,
Ian


#13

Hi again Ian

I think the message is talking about this… when you installed all the software from http://www.ghielectronics.com/support/dotnet-micro-framework, one of them was the GHI 4.2 installer (item 3). In that installer, there’s an option to tick “install drivers”, it’s item 7 on the setup screen. That’s all the driver setup means.

So from there, head into “STDfu Tester” and “Loading Tinybooter” section


#14

@ rcplaneguy: On a side note is it possible to build a model plane like a glider? I want to be able to have a long endurance platform for crime fighting that rapidly gets airborne via steam driven catapult.


#15

Brett, thanks, I will try reinstalling the software package.

Kurtnelle, tough call. A glider isn’t going to do it for you I suspect as it will only fly for a few minutes. Unless you are very skilled at catching thermals. If you are looking at an aerial platform for a camera I assume you are going to be using it in an urban area where thermals are not likely to be found. If that’s what you are looking to do I would suggest an electric powered glider. These are easy to get, easy to fly, and can remain airborne for up to half an hour with careful use of the throttle. They are also relatively cheap. A reasonable size one (2m span) can be bought for a few hundred dollars (AUD) and the radio for about $AUD250. Cameras are also cheap. I have a “keychain” camera I bought for $29. It’s about half the size of a matchbox, and can record quite a lot of video, at least half an hour’s worth I would think. I’ve never filled it up. If you are going more sophisticated again and looking at a live video downlink from the plane, the gear to do this is also readily available, but we are now talking not much change out of a thousand dollars, depending on the range you need. Try Googling FPV or “first person view”. The technology is out there and is readily available.

You could also look at a quadcopter (four rotors) or hexa- or octocopter (six or eight rotors). There are many of these available althought they are expensive. Many are designed specifically for aerial photography and FPV and have “steadycam” mounts built in. They are more difficult to fly but are very maneuvarable and can go pretty much anywhere as long as the radio link and video downlink can be maintained. Here in Australia there are already strict guidelines (but no legislation, yet…) controlling the use of quadcopters with FPV, mainly related to privacy (you could fly one into anyone’s back yard and look in through their windows), and terrorism. It is theoretically possible to attach a bomb to one, then fly it to your target from 20km away… Scary stuff.


#16

Brett, reran the installer and made sure I clicked “install” when it wanted to install the drivers. At the end if asked me if I wanted to update my firmware on my device and to select my device. But Cerberus was not an option. It only showed Spider, Hydra, G120 and Cobra. So I bypassed this step (with great trepidation). I’ll try the next steps…

Ian


#17

Well, more confused than ever.

Successfully reloaded TinyBooter and TInyCLR onto the Cerberus. A bit confusing but I got there in the end.

But… created a brand new project and then just attempted to compile it. Got some link errors (the original one about LCDRotation is still there, but it’s only a warning so I’m ignoring it right now). First off, the reference to “Gadgeteer” in the References in Solution Explorer refers to version 2.41.0.0. I know I selected SDK 4.2 to create the project. Then there are a whole lot of references missing for assembly Gadgeteer, it needs different versions (2.41.2821.0) of lots of other modules like “mscorlib”, which are all version 2.42.0.0 in the References. What’s more I get a message saying GadgeteerApp1 (which appears to be the default project name) requires “Gadgeteer V 2.41.0.0” and yet it exists in the references.

Way too late, I’m going to bed (nearly 2am…)


#18

@ rcplaneguy - I have a strange issue when i create a 4.2 it puts in the 4.1 Gadgeteer.dll…
So i have to remove the Gadgeteer.dll and readded the 4.2 version - go figure


#19

@ rcplaneguy, Attach a screenshot of the error that you’re getting. By the time you read this it will be morning. If so then “Good Morning”.


#20

Ian, great to hear you made some progress on the firmware front. Now we need to get you a working project !

I created a new Gadgeteer 4.2 project, with a Cerberus mainboard on the design surface, and saved it. I’ve then zipped that folder and posted it to SkyDrive. http://sdrv.ms/10Tbx7h is the location, you’re looking for IanTestApp.zip