Main Site Documentation

Hydra shows up as COM port if Music Module connected


#1

Hi all,

I have a problem with my Hydra and the Music 1.0 module.
My setup is as follows:
I have a Hydra with the lates networking firmware, an ENC28 (Socket 3), USB Client DP (Socket 2) with external power (19V 4A) and a Music module (Socket 4).

If the Music module is connected after power on I find the COM port (GPS Camera Detect) in the Device Manager. Without the Music module the Hydra correctly shows as “GHI .NET Micro Framework USB Debugging Interface”.
On some verry rare cases it also boots correctly with the music module connected.

I already tried reinstalling the firmware without any change.
Any Idea what I can do?

Uwe


#2

Do you see this with both S sockets?

Looks like the music module is blocking the DATAFLASH on power up!


#3

Hi Gus,

now I replaced the firmware by the non Ethernet one, removed the ENC28 and put the Music module on socket 3 instead of 4.
After that Hydra boots correctly all the time.
The Music module works somehow: music.SineTest() starts the sound but often does not succeed stopping it after 2 seconds.
So what does this mean? Is my Music module broken?
I want to use Music and Ethernet at the same time. Should I investigate other posibilities (Ethernet on Port 4 or some wireing to get both using the same SPI?)
I thought there were others that used Music and Ethernet on Hydra so i think it should work somehow.

Thanks
Uwe


#4

I did some futher tests: (all with non ethernet firmware)

The following combinations do NOT work:
ENC28 on socket 4 and Music on socket 3
ENC28 on socket 3 and Music on socket 4

The following combinations do work:
just ENC28 on socket 3
just ENC28 on socket 4
just Music on socket 3
just Music on socket 4

So the issue can only be seen if both S ports are used.
Any idea?


#5

You said the first combination that causes the device to come up in bootloader mode is when you connect the music module after power-up. Remember, these devices are NOT meant to be hot plug, so you should never do that… always add modules and lastly power the device up and attach via USB to a PC. Can you confirm that your last sets of tests were validated when you have not powered up the device, adjusted the modules, then attached the device to the PC?


#6

How is coordination done between the ethernet and music modules to share access to the shared SPI signals that they use? Funny things would happen if there was not some of mechanism preventing simultaneous access.


#7

@ Brett
I was a bit lazy of writing every step I did. I always switched power off before I changed the configuration.

@ Mike
I think if I see the COM port after power up this is the Atmel boot loader or the tiny booter. The firmware which deals with SPI ports for Ethernet or Music might not be running at that time. Am I right?


#8

@ UweTfromG

Do you have a Multimeter that can see if any of the pins on the music module are shorted to ground. Because the Data flash shares the same SPI pins as Sockets 3 and 4, Any grounding of the SPI pins can cause the Hydra to bypass the flash and go into Atmel SAM-BA bootloader which is the COM port that you are seeing.

Also try a different cable on the music module. Perhaps a short may exist there.


#9

Hi Aron,
I checked all pins against ground and the supply voltages: No short circuit.
Additionally I replaced the cable - no effect.

As Long as I only connect the Music module I don’t have a problem. If I have both: Music and Ethernet then I got into the Atmel boot loader.
It seems that both together draw the SPI to ground.
Or can it be something on the Hydra?


#10

Do you have any other SPI modules that you can see if having them both attached causes Hydra to Bootloader mode?


#11

Sorry for the late response

I tried two ENC28 on port 3 and 4 and everything is fine.
Only in combination with the Music module I reach the Atmel bootloader.
Is there anything else I can try or measure?


#12

Are you running any program on your device while this issue is occurring, or is it happening from merely plugging in the Music Module without any code?


#13

I don’t have any specific code.
since it is jumping into the atmel boot loader I thought it doesn’t matter what code is on the device.


#14

Yep, I would agree, but you can prove it by just deploying a LED blink program


#15

@ UweTfromG

The only thing left that I can think to do is if you have the ability, send us your device and modules that appear to be causing this and we can analyze them here.

I you are to do this, please include any and all information and steps so that we can troubleshoot the issue. To contact us, go to the Contact Us link under the Company menu listing above.


#16

Has anyone with an ENC28 and Music Module and Hydra tested this to make sure it’s a one-off or reproducible on any kit?


#17

@ Aron
thank you for the offer to check my modules.
I’m from Germany. So I guess shipping to the US and back might be more expensive than bying another Music module :frowning:

I like the suggestion of Brett: can anyone check that it works in general?
Just connect ENC28 on port 3 and Music on port 4; power up and check if it shows up as FEZ Hydra instead of the GPS camera.
If I’m sure that this is caused by a broken music module I would by a new one.

Are there different Hardware revisions of the modules? I think my german dealer still has some older modules. E.g. he still sells the T35 instead of the TE35 displays.
My Hydra is Rev. 1.2, Music is Rev. 1.0, ENC28 is Rev. 1.1.


#18

@ UweTfromG

I just tested the same module combination and it is not causing the issue that you are reporting. The only thing that we believe it could be is the music module is shorting one or all of the SPI pins to disable the dataflash.


#19

It cannot be a simple short to ground or VCC. I measured that it is working on some rare cases. What I did not test yet is a short between the different SPI pins.
I will do this check and if I don’t find an issue I’ll by a new module.
Thanks for your help.


#20

Bad news:
I’ve got my new Music module and it does not change anything.
So the Ethernet module is not the problem, the Music module is not the problem and the cables are not the problem.
I also used different USB ports including a powered hub and an USB power supply.
It works every 20 tries or so but most of the time I get the COM port
Any idea what I can do?