Hows the water? Win10 as a development host

Is there anyone doing serious NETMF dev work from within Windows 10? That is, not just VS programs, but some or all of:
building 4.3 firmware with Keil
building 4.4 firmware with any toolchain
running the Dfuse family of programs
running MFDeploy (4.3 and 4.4)
running ST-Link

I need some of the Win10 functionality on my hardware host (not just a VM) and I’m just trying to work out if this is going to interfere with low-level NETMF work. So I thought I’d see if anyone else has had success here.

Thanks!

Yes to all and without issue.

5 Likes

@ Justin - And here I thought you were such a cautious fellow, you early adopter, you. Bravo.

As developers we live on the edge sometimes as it is what keeps us going.

My current setup:
Windows 10 build 10159
VS2015 Community RC
SDK 2015 R1 Pre-Release 3

The only issues I have encountered so far is this error on deployment with just vs2015
Resolve: unknown type: System.Diagnostics.DebuggerBrowsableState
Error: ff000000

This occurs if I created a class having any public properties, then using this class in code. My workaround is to move everything into the program.cs then redeploy.

Income, caffeine, toys and a challenge is what keeps me going. Being first and/or best to market with solutions to challenges is what brings income, caffeine and toys, so yeah, I agree with you in an indirect sort of way.

Thanks for your response! I have, in fact, upgraded and in a show of true success for Win10, nothing much has changed except where I notice that stuff got better. I have been using Win10 internal builds for a long time, but always on a laptop or in a VM. The leap here was upgrading my main VM host and my main machine for ‘special drivers, emulators and fiddly hardware bits’ to Win10. It has been painless so far.

I’ve succeeded in building firmware and deploying from Dfuse, MFDeploy and ST-Link under multiple NETMF SDKs, and my Xamarin cross-platform projects all built fine, so it all looks good.

1 Like

@ kirklynk - “I think” I was having that same issue months back so I stopped using vs15. I found that if I had a class with public properties using c# shorthand notation:

public string FirstName {get; set;}

That caused the error.

If I moved back to old school that solved the issue.

private string firstName;
public string FirstName
{
get { return firstName; }
set { firstName = value; }
}

As I recall, @ Justin used to be a stunt bike rider and has led a life of pushing limits of all sorts :smiley:

2 Likes

@ terrence - Thanks for the insight. I will definitely tried that tonight and see what happens

@ ianlee74 - And the scars to prove it…

ok, so here’s a weirdness i’m seeing when using Win10 and SDK 2015 R1 B3 with VS2013 Update 4. Can anyone repro?

I have a simple test app (running on a Panda3). When I deploy, like many people report, I have to reset the device to allow deployment to move along (the usual “iteration N” message). But then, after resetting, the debugging thread can’t connect to the board. I can reset the board as many times as I like, it never appears to connect in the debugging mode. Typical deployment sequence shown below (note, I’m just hitting F5 in VS to deploy the same code as is already running).

[quote]Iteration 54
Opening port \?\usb#vid_1b9f&pid_0102#8&19facce&0&4#{a5dcbf10-6530-11d2-901f-00c04fb951ed}
Attaching debugger engine…
… debugger engine attached!
Querying device assemblies…
Found Assembly mscorlib 4.3.1.0
Found Assembly Microsoft.SPOT.Native 4.3.1.0
Found Assembly Microsoft.SPOT.Hardware 4.3.1.0
Found Assembly Microsoft.SPOT.Graphics 4.3.1.0
Found Assembly Microsoft.SPOT.TinyCore 4.3.1.0
Found Assembly Microsoft.SPOT.IO 4.3.1.0
Found Assembly System.IO 4.3.1.0
Found Assembly Microsoft.SPOT.Hardware.Usb 4.3.1.0
Found Assembly Microsoft.SPOT.Hardware.SerialPort 4.3.1.0
Found Assembly Microsoft.SPOT.Hardware.PWM 4.3.1.0
Found Assembly GHI.Pins 4.3.7.9
Found Assembly Pan3displaytest 1.0.0.0
Adding pe file C:\Program Files (x86)\GHI Electronics\NETMF v4.3 SDK\Libraries\le\ghi.pins.pe to deployment bundle
Adding pe file C:\Users\brpound\OneDrive\Development\Fez_Projects\Pan3displaytest\Pan3displaytest\bin\Debug\le\Pan3displaytest.pe to deployment bundle
Attempting deployment…
Incrementally deploying assemblies to device
All assemblies on the device are up to date. No assembly deployment was necessary.
Assemblies successfully deployed to device.
Restarting interpreter…
Attaching to device…
Waiting for device to initialize…
The debugging target and the debugger engine failed to initialize because of unspecified device errors.
The debugger engine thread has terminated unexpectedly with error ‘Could not reconnect to the debugging target after rebooting it.’.
[/quote]

Code is simple and designed to protect against the normal debugging engine not given sufficient time:

        public static void Main()
        {
            Thread.Sleep(5000);
            InputPort ldr = new InputPort(GHI.Pins.FEZPandaIII.Gpio.Ldr0,false,Port.ResistorMode.PullUp);
            while (ldr.Read()==true)
            {
                Thread.Sleep(200);
            }
            bool led1 = true;
            bool led2 = false;
            OutputPort led1OP = new OutputPort(GHI.Pins.FEZPandaIII.Gpio.Led1, led1);
            OutputPort led2OP = new OutputPort(GHI.Pins.FEZPandaIII.Gpio.Led2, led2);
            OutputPort led3OP = new OutputPort(GHI.Pins.FEZPandaIII.Gpio.Led3, led1);
            OutputPort led4OP = new OutputPort(GHI.Pins.FEZPandaIII.Gpio.Led4, led2);
            Debug.Print(Resources.GetString(Resources.StringResources.String1));
            while(true)
            {
                led1OP.Write(!led1);
                led2OP.Write(!led2);
                led3OP.Write(!led1);
                led4OP.Write(!led2);
                led1 = !led1;
                led2 = !led2;
                Thread.Sleep(20);
            }
        }

Of course it’s on Win10 so there’s a chance that’s to blame - anyone still with Win8.1 or earlier able to test ?

I installed win10 build 10130 from an iso… and was unable to upgrade to any of the subsequent builds.

They didn’t put out an ISO (that I saw anyway) for 10158 or 10159, so I had to just twiddle my thumbs until they actually put up a new ISO.

But they seem to have released an ISO for build 10162… so I am going to install that fresh right now.

I hope 10162 fixes wifi with my laptops internal adaptor. It worked with 10074 but failed with 10130.

I had a little issue with the MetaDataProcessor and had to run over to http://netmf.codeplex.com/workitem/221 to solve it, but after that it was just running fine with Windows 10 Build 10162 + VS2015RC + NetMf 4.3.2 and without wifi issues … actually this is posted using that setup over wifi.

1 Like

@ andre.m -
“are you sure your username is registered as windows insider user”

Yes

"and your windows insider user is registered to only one win 10 as primary account? "

Meaning? I can only update one PC using the insider preview?

My desktop PC and my laptop both have windows 10 on one partition. Ive just been having issues upgrading my laptop (haven’t tried my pc yet)

Build 10162 works on my laptop. Even the wifi works now, which is great. It took awhile to hunt around and find where to manually add a wifi entry for a non-broadcasting SSID though…lol

You’d think there’d be a link or button on the "manage wifi settings’ form to manually add a network that wasn’t listed.

That hasn’t been my experience. Is there some documentation that states this? I have five machines (physical and VM) that are all running against the same Microsoft account and the same Connect registration (and two more on another registration) and they are all getting upgrades (in fact, they all got 10162 in the last 24 hrs). I’m not aware of any one-image-per-account limitations.

@ andre.m - Three of the seven total - two upgrades and one new vm from ISO

To the best of my knowledge and experience, that’s incorrect.

I have three PCs here with me that I’ve updated under the same insider account.

Pete

You need to enable “fast ring” otherwise you will not see a lot of new builds.

Same here. I had Developer mode on, logged in with my insider account, had fast ring enabled, windows was fully activated, other updates came through fine.

It would -see- the new build, and download it, and go through the lengthy install/reboot process, and at the end of it all, it would just come back with the original (10130) build, with a notification that said that the update failed, and no real clues as to why)

I tried it about 10 times (letting windows update re-download the update every time). I tried all sorts of things… turning off windows defender, trying without any usb devices connected (in case it was a driver issue), trying it at work and at home. It just refused to update from build 10130 (which, as I mentioned, was installed clean from the microsoft ISO)

But, in the end, I just installed the 10162 build from scratch, and now I am reinstalling everything else.

Im wondering if the issue had anything to do with the fact that build 10130 did not support my internal wifi card correctly. (previous builds did, and 10162 does). I had to use an external usb wifi connector when 10130 was running. Maybe the upgrade process kept trying to use the internal card during the installation instead of the usb adapter. Or maybe it had something to do with my dual booting with windows 7.