Main Site Documentation

Hot burning FEZ Domino when connected to USB


#1

Hello,

I have FEZ Domino and I tried to connect it to a external board. The external board has 12 V stabilized voltage (11.63V according to my voltmeter). I used the external pins on Domino - Vin and GND because I saw that these pins are connected directly to the original power supply for the board. The result was not every time Domino booted normally sometimes, but sometimes I have to press the Reset button to boot normally.

Then I tried to connect it to the PC only with the USB cable and everything was normal.

After that I tried to supply the external board from the original Domino’ power supply using Vin and GND. Then the Domino didn’t boot and when I touched the chip it was hot. I disconnected it and wait a little bit to cool down and connected it to USB. But the only result was that the chip is getting hot.

Do you think it still has hope for it and what should I do or I should wait for my new one to be delivered?

Thank you in advance,
Boyan


#2

@ pxpress - The power coming from USB goes through a regulator to add a 3.3V supply to the existing USB 5V supply. Apply 12V to any part of that should be considered last resort; like when it’s already destroyed, but you want to see it smoking, for good measure.

Your Domino has a power connector on it; whatever you apply to it will go through a regulator. The result is 3.3V, 5V, and heat. The voltages don’t change unless you apply less than 5V. The higher the voltage you apply to the regulator, over 5V, the more heat will be generated. That is different than jamming 12V into the FEZ.

If whatever you are controlling with the FEZ runs on 12V you must supply it with 12V independently of the FEZ and use a lower-voltage switching component to turn the component on and off. If you have sufficient power on the 12V coming in, you can run both the component and the FEZ (via the power port and regulator) off of the same supply.


#3

-Does your OS identify the Domino (.NET Debuggable Device)?
-Find MFDeploy on your PC and run it
-Select USB>Usbizi
-Click 'ping’
you should see “Pinging… TinyCLR”


#4

It is not recognised as any device. Only the LPC starts to getting hot and I disconnect it before it starts to burn and smoke.


#5

RIP Domino :frowning:


#6

Maybe tried to get a Domino’s Pizza :clap:


#7

Thanks for the encouraging replies. Now, I am waiting for a new Domino, so I hope that everything will be fine :slight_smile:


#8

I am not sure that it is not my fault, so I think it is better not to complain about it.


#9

Good luck with the new one - just remember the way you connect it to power is important. You might find you could replace the USBizi chip on the device and get another working Fez if you wanted (Domino uses USBizi144)