Main Site Documentation

Help with Spider and USB


#1

Hi,

Just received my FEZ spider and I am having issues getting my computer to recognize it when plugged in to the USB (through the DP client module).
The device powers up (red light on both main board and module) however the computer does not see the device.
Tried MFdeploy with no effect.

Help.


#2

Probably weak power. Use powered hub or add power pack. You can also try to connecting it directly to PC without hubs in the way.

Welcome to the community.


#3

Ok I will try this

What are the Max. Amps that can be used for the module?


#4

If you mean what are the max amps that your power supply can provide then there really is no max. What really matters is how much current (amps) you are actually using. If you’re just using commercial Gadgeteer modules and not doing any of your own circuits with the Extender module then this isn’t really something you should have to worry about. If you have a 5A wall wart supply around then that should work just fine as long as it’s the correct voltage.


#5

Hi again,

Still no luck getting my computer to see it. It is plugged in directly to the computer (no USB hubs) It is USB 2 with up to date drivers.

I am beginning to think the unit is faulty.


#6

Hi,

Have your tried going through the update firmware process?

I know my hydra didn’t get detected, then i shorted to 2 pins to start the firmware process, once the firmware was updated it just worked.


#7

Does the LED come on on your board? Have you tried another PC? What do you see in device manager when you plug it in?


#8

Running into the same issue on a new Spider board I just got. On one machine when I plug it in to USB, nothing happens at all on the PC (no USB connection sound, no indication that the PC sees the Spider at all), although the USB Client DP and the Mainboard LEDs both light up. Tried the firmware updater, but it can’t see the board, nor is the board showing up in MFDeploy.

On a second machine, I do get the USB connect sound, but it says that the USB device has malfunctioned and cannot be recognized. Tried uninstalling from device manager and plugging it in fresh…no luck. Tried firmware update from the 2nd machine, still could not see the board (and yes, in both cases, I set the switches for firmware update mode).

In all of my attempts, I’m connecting direct, no USB hubs, and I’ve tried both USB alone, as well as USB + separate wall wart to ensure there was plenty of power.

Any suggestions in terms of troubleshooting would be welcome.


#9

Check reset pin voltage.


#10

Sorry for my ignorance, but how do I know which pin to check? Is this documented somewhere?

Also, some additional info…if I have the T35 display attached, it does display the tinybooter info, so I’m pretty sure the board isn’t completely dead.


#11

It is pin 70 on EMX module. But since your T35 is working it is not what I was thinking. But measure it just in case.


#12

Further weirdness. My original Spider board, which was working fine, and which showed up as a GHI debuggable device (or something like that) is now showing the same symptom when connecting via USB.

I was originally attempting to build out the Gadgeteer Arcade console, which is when the new board started acting hinky. Then I swapped in my known good mainboard, and now it’s failing to connect to the PC properly. Wondering whether one of the components in the new kit is bad, and causing the issues, though I have disconnected everything but the USB client DP module, and I’m still getting USB errors when connecting either Spider mainboard.

But the older mainboard, which had been running my IR heli controller, is definitely still working…I hooked it back up to the controller, and it’s still working fine. Just won’t connect via USB.

Argh!!!


#13

@ Architect and @ Gus

Turns out it was a PEBCAK in my case. I had connected my USB Client DP module to Z instead of DI. Thankfully, I didn’t release any magic smoke, and once connected properly the board is visible via USB. Man, do I feel stupid. :-[


#14

Impossible. :slight_smile:


#15

@ ian

Never underestimate my ability to break stuff. I have a gift in that area. :slight_smile:


#16

From Urban Dictionary:

[quote]

PEBCAK

RTFMs big brother, it stands for Problem Exists Between Chair and Keyboard. A popular term among office network engineers and IT support departments, it arose due to a need to descretly describe [edit] nice smelling [/edit] users (who falsely believe the system or computer is at fault) in thier presence with a suitably technical and legitimate-sounding term.[/quote]


#17

@ ransomhall

Yup. Except for the whole arrogant thing. :slight_smile:

I’m rather fond of the term, having started my IT career doing helpdesk work.


#18

I had to lookup the frickin’ acronym! I edited out the arrogant part.


#19

I prefer to call those ID-10-T errors :wink:


#20

Ok

So I’ve tried a couple things here - still no luck!

]lights on the DP module and spider are on. tried with the T35, it lights up but its just a white screen

tried different USB ports, different cables and different computer
it does not show up as anything when plugged in (no sound, etc.)

Any other suggestions??